diff mbox series

[bug#67069] gnu: daikichi: fix cross-compilation.

Message ID b88b9268110e743e24d4c67dd04abc55857e091b.1699698534.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#67069] gnu: daikichi: fix cross-compilation. | expand

Commit Message

Z572 Nov. 11, 2023, 10:28 a.m. UTC
* gnu/packages/textutils.scm (daikichi): fix cross-compilation.
[inputs]: add diffutils.

Change-Id: I7e46a3f61a869c10f3491e1397232125ccf76149
---
 gnu/packages/toys.scm | 2 ++
 1 file changed, 2 insertions(+)


base-commit: 61c527227ceebdad8da2d52214b253a48323cbb9

Comments

Mathieu Othacehe Nov. 25, 2023, 1:38 p.m. UTC | #1
> * gnu/packages/textutils.scm (daikichi): fix cross-compilation.

Applied, thanks,

Mathieu
Liliana Marie Prikler Nov. 25, 2023, 10:18 p.m. UTC | #2
Am Samstag, dem 11.11.2023 um 18:28 +0800 schrieb Zheng Junjie:
> * gnu/packages/textutils.scm (daikichi): fix cross-compilation.
> [inputs]: add diffutils.
> 
> Change-Id: I7e46a3f61a869c10f3491e1397232125ccf76149
> ---
>  gnu/packages/toys.scm | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
> index 21d5279e85..2fa47315c0 100644
> --- a/gnu/packages/toys.scm
> +++ b/gnu/packages/toys.scm
> @@ -5,6 +5,7 @@
>  ;;; Copyright © 2019, 2022 Liliana Marie Prikler
> <liliana.prikler@gmail.com>
>  ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
>  ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
> +;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -70,6 +71,7 @@ (define-public daikichi
>                        (search-input-file inputs
>                                           (string-append "bin/"
> cmd)))))))))
>      (inputs (list bash-minimal coreutils sed
> +                  diffutils
>                    fmt gmp))
>      (native-inputs (list pkg-config))
>      (home-page "https://gitlab.com/lilyp/daikichi")
I only noticed this now that it's been pushed, but are you sure that
inputs is correct?  As far as I know, diffutils are only used for the
tests, so it ought to be native-inputs, no?

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 21d5279e85..2fa47315c0 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2019, 2022 Liliana Marie Prikler <liliana.prikler@gmail.com>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -70,6 +71,7 @@  (define-public daikichi
                       (search-input-file inputs
                                          (string-append "bin/" cmd)))))))))
     (inputs (list bash-minimal coreutils sed
+                  diffutils
                   fmt gmp))
     (native-inputs (list pkg-config))
     (home-page "https://gitlab.com/lilyp/daikichi")