diff mbox series

[bug#66158,v2] gnu: node-lts: Update to 18.18.2.

Message ID b865aca9b05e55238918ea21270ca44055616927.1698422549.git.jlicht@fsfe.org
State New
Headers show
Series [bug#66158,v2] gnu: node-lts: Update to 18.18.2. | expand

Commit Message

Jelle Licht Oct. 27, 2023, 4:02 p.m. UTC
From: Jelle Licht <jlicht@fsfe.org>

* gnu/packages/node.scm (node-lts): Update to 18.18.2.
[arguments]<phases>: Add 'install-node-gyp-wrapper phase.

Change-Id: I6b17de33313505558a8fa9560126adef486fd0e3
---
I tried my hand at introducing a small wrapper script that works around the
node-gyp regression introduced in the version of npm bundled with node 18.18.2.

It's not quite clear yet whether upstream considers this a regression that
will still be fixed or just behaviour that be kept as-is going forward.

This patch series also leaves Node vulnerable to a recently reported CVE in
many HTTP2 server implementations, such as nghttp2, but I believe this can be
addressed by https://issues.guix.gnu.org/issue/66658

Changes in v2:
 - Re-bump from 18.18.0 to 18.18.2
 - Fix 'node-gyp' regression.

 gnu/packages/node.scm | 25 ++++++++++++++++++++++---
 1 file changed, 22 insertions(+), 3 deletions(-)


base-commit: 2ff8de3657a5c9d0abf67bb4705251b23d97702e

Comments

Christopher Baines Nov. 3, 2023, 9:53 a.m. UTC | #1
jlicht@fsfe.org writes:

> From: Jelle Licht <jlicht@fsfe.org>
>
> * gnu/packages/node.scm (node-lts): Update to 18.18.2.
> [arguments]<phases>: Add 'install-node-gyp-wrapper phase.
>
> Change-Id: I6b17de33313505558a8fa9560126adef486fd0e3
> ---
> I tried my hand at introducing a small wrapper script that works around the
> node-gyp regression introduced in the version of npm bundled with node 18.18.2.
>
> It's not quite clear yet whether upstream considers this a regression that
> will still be fixed or just behaviour that be kept as-is going forward.
>
> This patch series also leaves Node vulnerable to a recently reported CVE in
> many HTTP2 server implementations, such as nghttp2, but I believe this can be
> addressed by https://issues.guix.gnu.org/issue/66658
>
> Changes in v2:
>  - Re-bump from 18.18.0 to 18.18.2
>  - Fix 'node-gyp' regression.
>
>  gnu/packages/node.scm | 25 ++++++++++++++++++++++---
>  1 file changed, 22 insertions(+), 3 deletions(-)

Looking at QA, there seems to be some issues on aarch64-linux. The build
logs do differ between the failed builds, so I've submitted a few more.
Jelle Licht Nov. 5, 2023, 1:42 p.m. UTC | #2
Christopher Baines <mail@cbaines.net> writes:

> jlicht@fsfe.org writes:
>
>> From: Jelle Licht <jlicht@fsfe.org>
>>
>> * gnu/packages/node.scm (node-lts): Update to 18.18.2.
>> [arguments]<phases>: Add 'install-node-gyp-wrapper phase.
>>
>> Change-Id: I6b17de33313505558a8fa9560126adef486fd0e3
>> ---
>> I tried my hand at introducing a small wrapper script that works around the
>> node-gyp regression introduced in the version of npm bundled with node 18.18.2.
>>
>> It's not quite clear yet whether upstream considers this a regression that
>> will still be fixed or just behaviour that be kept as-is going forward.
>>
>> This patch series also leaves Node vulnerable to a recently reported CVE in
>> many HTTP2 server implementations, such as nghttp2, but I believe this can be
>> addressed by https://issues.guix.gnu.org/issue/66658
>>
>> Changes in v2:
>>  - Re-bump from 18.18.0 to 18.18.2
>>  - Fix 'node-gyp' regression.
>>
>>  gnu/packages/node.scm | 25 ++++++++++++++++++++++---
>>  1 file changed, 22 insertions(+), 3 deletions(-)
>
> Looking at QA, there seems to be some issues on aarch64-linux. The build
> logs do differ between the failed builds, so I've submitted a few more.

Pushed to master as ab94e80601a5b23f44e7455b3443457b4a99a1e5.

At least the aarch64-linux build seems to have worked out.  I've locally
verified that things build for i686-linux too. Please Cc me if there are
still any issues with it.

- Jelle
diff mbox series

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index d769066dc4..6e30ad486a 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -738,14 +738,14 @@  (define-public llhttp-bootstrap
 (define-public node-lts
   (package
     (inherit node)
-    (version "18.17.1")
+    (version "18.18.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://nodejs.org/dist/v" version
                                   "/node-v" version ".tar.gz"))
               (sha256
                (base32
-                "0dachvhf5jxrb1av8mn2dikbhwklxsgc9y2zg4h50fcwh5d54mqi"))
+                "0ci1faxjsbp0lv05kskh5anfljn6zawqcf7dawiby5d5qg7x572h"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -903,7 +903,26 @@  (define-public node-lts
                                           "/lib/node_modules/npm/node_modules"
                                           "/tar/lib/write-entry.js")))
                  (substitute* file
-                   (("this.stat.nlink > 1") "false")))))))))
+                   (("this.stat.nlink > 1") "false")))))
+           (add-after 'install 'install-node-gyp-wrapper
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (dir (string-append out "/lib/node_modules/npm/bin/node-gyp-bin"))
+                      (file (string-append dir "/node-gyp")))
+                 (mkdir-p dir)
+                 ;; See https://github.com/npm/cli/issues/6842
+                 (call-with-output-file file
+                   (lambda (port)
+                     (format port "#!~a/bin/sh
+if [ \"x$npm_config_node_gyp\" = \"x\" ]; then
+  ~a/bin/node \"~a/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js\" \"$@\"
+else
+  \"$npm_config_node_gyp\" \"$@\"
+fi"
+                             (assoc-ref inputs "bash")
+                             out
+                             out)))
+                 (chmod file #o555))))))))
     (native-inputs
      (list ;; Runtime dependencies for binaries used as a bootstrap.
            c-ares-for-node