diff mbox series

[bug#74497,20/46] gnu: Add python-puremagic.

Message ID b85fd86dc570184e3f6ed84b31eb10cad3f3cb6b.1732384228.git.sharlatanus@gmail.com
State New
Headers show
Series Astro update 2024/11. | expand

Commit Message

Sharlatan Hellseher Nov. 23, 2024, 7:51 p.m. UTC
* gnu/packages/python-xyz.scm (python-puremagic): New variable.

Change-Id: I326d15cdf6eb088f456954c28fd735bc1890840a
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3872b511a1..4ec6407571 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12827,6 +12827,29 @@  (define-public python-pure-eval
 abstract syntax tree (AST) nodes without side effects.")
     (license license:expat)))
 
+(define-public python-puremagic
+  (package
+    (name "python-puremagic")
+    (version "1.28")
+    (source
+     (origin
+       (method git-fetch)               ;no tests in PyPI archive
+       (uri (git-reference
+             (url "https://github.com/cdgriffith/puremagic")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0sffrjjqh37ijwnggyvs2rfm4iwaz2m395wqg0x727wv8i0x3f3b"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-pytest))
+    (home-page "https://github.com/cdgriffith/puremagic")
+    (synopsis "Pure Python implementation of magic file detection")
+    (description
+     "This package implements a functionality that will identify a file based
+off it's magic numbers.")
+    (license license:expat)))
+
 (define-public python-ast-decompiler
   (package
     (name "python-ast-decompiler")