diff mbox series

[bug#55030,v2,25/34] gnu: Add elm-random.

Message ID b842f0140a05c7427fad42b7034399c5275f694e.1652890702.git.philip@philipmcgrath.com
State Accepted
Headers show
Series gnu: elm: Update to 0.19.1. Add build system & importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath May 18, 2022, 6:11 p.m. UTC
* gnu/packages/elm.scm (elm-random): New variable.
---
 gnu/packages/elm.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index d17a3f2487..c2e4b65b77 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -560,3 +560,21 @@  (define-public elm-debois-elm-dom
 Use this if you need to discover geometry information (width, position, etc.)
 of rendered elements.")
     (license license:asl2.0)))
+
+(define-public elm-random
+  (package
+    (name "elm-random")
+    (version "1.0.0")
+    (source
+     (elm-package-origin
+      "elm/random"
+      version
+      (base32 "0z0znkwfs35xiabk6pa9yqwsq03jssgd7jmsj1kk000mikfm7f39")))
+    (build-system elm-build-system)
+    (propagated-inputs (list elm-time elm-core))
+    (home-page "https://package.elm-lang.org/packages/elm/random/1.0.0")
+    (synopsis "Generate random numbers and values in Elm")
+    (description
+     "Need to generate random numbers?  How about random game boards?  Or
+random positions in 3D space?  This is the package for you!")
+    (license license:bsd-3)))