diff mbox series

[bug#52827] build/python: Improve error output in sanity check.

Message ID b7f3097b39b1c1c26cebc25b56cdf4571d1709d0.1640629059.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#52827] build/python: Improve error output in sanity check. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Dec. 27, 2021, 6:21 p.m. UTC
Instead of printing the "str()" representation of the excaption, print the
"repr()" representation. This will print the name of the exception and thus
ease understanding the actual error.
---
 gnu/packages/aux-files/python/sanity-check.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Hartmut Goebel Dec. 27, 2021, 8:14 p.m. UTC | #1
Of course, this needs to go to core-updates.

Pinging @Lars-Dominik: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=52827
Lars-Dominik Braun Dec. 28, 2021, 1:37 p.m. UTC | #2
Hi Hartmut,

the change is trivial and looks good to me.

Do we have a package that currently fails with an exception?

Cheers,
Lars
Hartmut Goebel Dec. 28, 2021, 1:56 p.m. UTC | #3
Am 28.12.21 um 14:37 schrieb Lars-Dominik Braun:
> Do we have a package that currently fails with an exception?

Not currently. But you could test the effect with trytond-party 
@6dffced09ecda024e0884e352778c221ad066fd6 (merge core-update frozen).
Hartmut Goebel Jan. 15, 2022, 8:43 p.m. UTC | #4
Pushed to core-updates as fab871ae7a51f0e705eb4cc8ffffe1a0822e259f
diff mbox series

Patch

diff --git a/gnu/packages/aux-files/python/sanity-check.py b/gnu/packages/aux-files/python/sanity-check.py
index a84f8f03c0..182133bb3d 100644
--- a/gnu/packages/aux-files/python/sanity-check.py
+++ b/gnu/packages/aux-files/python/sanity-check.py
@@ -44,7 +44,7 @@  for dist in ws:
         pkg_resources.require(req)
         print('OK')
     except Exception as e:
-        print('ERROR:', req, e)
+        print('ERROR:', req, repr(e))
         ret = 1
         continue