diff mbox series

[bug#64556] gnu: Add emacs-sweet-theme.

Message ID b78e5694942e7ef95279ab07a6dc3413507061bf.1689001912.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64556] gnu: Add emacs-sweet-theme. | expand

Commit Message

Ahmad Draidi July 10, 2023, 3:11 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-sweet-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: b7be0a999df8984fee8bd9d283b8fbe7e4da879d
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fb36d7d29d..09c0bb7b1d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11988,6 +11988,28 @@  (define-public emacs-counsel
 @end itemize")
     (license license:gpl3+)))
 
+(define-public emacs-sweet-theme
+  (let ((commit "78f741806ecebe01224bf54d09ad80e306652508")
+        (revision "0"))
+    (package
+      (name "emacs-sweet-theme")
+      (version (git-version "4" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/2bruh4me/sweet-theme")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1yqz15l6xa1vkll4gaa3jpr30vq3yjgbgadjilsmz5p8mblawhyx"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/2bruh4me/sweet-theme")
+      (synopsis "Emacs theme inspired by the GTK theme Sweet")
+      (description "Sweet is an Emacs theme inspired by the GTK theme with
+the same name.")
+      (license license:gpl3+))))
+
 (define-public emacs-swiper
   (package
     (name "emacs-swiper")