[bug#76910,v3,3/5] gnu: Add hy3.

Message ID b6f97f0edbc6aed7428a1d4119424eeea60bf0df.1743492882.git.wongandj@icloud.com
State New
Headers
Series Add Hyprland Plugins |

Commit Message

Andrew Wong April 1, 2025, 7:34 a.m. UTC
  * gnu/packages/wm.scm (hy3): New variable.

Change-Id: Id42dc76ab3440c7c651933c60b1ae30f8055afed
---
 gnu/packages/wm.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
  

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index e5bfe97c33..399075e668 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -573,6 +573,43 @@  (define-public hyprscroller
 jump mode, and installation through hyprpm.")
       (license license:expat))))
 
+(define-public hy3
+  (let ((commit "4014433d1c3d1bf36c6684cff14c23d538337070"))
+    (package
+      (name "hy3")
+      (version (git-version "0.48.1" "0" commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/outfoxxed/hy3")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0qrkb946zz4675qk1n4l7ik5w6n7v6m38yq9g0lwhqxmddrp2j89"))))
+      (build-system cmake-build-system)
+      (native-inputs (list gcc-14 pkg-config))
+      (inputs (list aquamarine
+                    eudev
+                    hyprgraphics
+                    hyprlang
+                    hyprutils
+                    libdrm
+                    libinput
+                    libxkbcommon
+                    mesa
+                    pango
+                    pixman
+                    wayland
+                    hyprland))
+      (arguments (list #:tests? #f))
+      (home-page "https://github.com/outfoxxed/hy3")
+      (synopsis "Hyprland plugin for an i3/sway-like manual tiling layout")
+      (description
+       "hy3 is a Hyprland plugin providing an i3/sway-like manual tiling layout,
+including node-based window manipulation and optional autotiling.")
+      (license license:gpl3))))
+
 (define-public i3status
   (package
     (name "i3status")