diff mbox series

[bug#63976] gnu: Add python-mudata.

Message ID b6ce59ff756491be94ba63edc8c7bade4d615ef8.1686322594.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#63976] gnu: Add python-mudata. | expand

Commit Message

nafkhamdc June 9, 2023, 2:56 p.m. UTC
* gnu/packages/bioinformatics.scm (python-mudata): New variable.
---
 gnu/packages/bioinformatics.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: dd587a4fefbd8841f609910af36e13aa890781b7
prerequisite-patch-id: c5352e197d46cff8e37f0ff85044983c550a9663

Comments

Ricardo Wurmus June 9, 2023, 3:09 p.m. UTC | #1
I simplified this a little and pushed this with commit
74443c30f3e20655a046c0d3ea236822ef130968.

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1caea80f86..13ae47d858 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3352,6 +3352,32 @@  (define-public python-mofax
 models trained with MOFA+ in Python.")
       (license license:expat))))
 
+(define-public python-mudata
+  (let ((commit "392f5464135d687fe64bc571d35cbf557b796ff0")
+        (revision "0"))
+    (package
+      (name "python-mudata")
+      (version (git-version "0.2.3" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/scverse/mudata")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "02h0k1q57589r0hdv8nwg1vk7g2ljvn5g66c47fy5gdilbm3gjws"))))
+      (build-system pyproject-build-system)
+      (propagated-inputs (list python-anndata python-h5py python-pandas python-flit-core))
+      (native-inputs (list python-numpy python-pytest python-zarr))
+      (home-page "https://github.com/scverse/mudata")
+      (synopsis "Python package for multi-omics data analysis")
+      (description
+       "Mudata is a Python package for multi-omics data analysis.
+It is designed to provide functionality to load, process, and store
+multimodal omics data.")
+      (license license:bsd-3))))
+
 (define-public python-pyega3
   (package
     (name "python-pyega3")