diff mbox series

[bug#44220] gnu: KDE Plasma: Update to 5.19.5.

Message ID b6a453794e1fbb8f4a81edf1abb36ad945f9c99b.1603660269.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#44220] gnu: KDE Plasma: Update to 5.19.5. | expand

Checks

Context Check Description
cbaines/submitting builds fail
cbaines/applying patch fail View Laminar job

Commit Message

Hartmut Goebel Oct. 25, 2020, 9:11 p.m. UTC
* gnu/packages/kde-plasma.scm (kdecoration, kscreenlocker,
  libkscreen, libksysguard): Update to 5.19.5.
---
 gnu/packages/kde-plasma.scm | 20 +++++++++++---------
 1 file changed, 11 insertions(+), 9 deletions(-)

Comments

Efraim Flashner Oct. 27, 2020, 8:59 a.m. UTC | #1
On Sun, Oct 25, 2020 at 10:11:44PM +0100, Hartmut Goebel wrote:
> * gnu/packages/kde-plasma.scm (kdecoration, kscreenlocker,
>   libkscreen, libksysguard): Update to 5.19.5.
> 

Assuming this doesn't break denlive, kdevelop or lxqt it looks good to
me. Although I haven't tried building it.
Hartmut Goebel Oct. 27, 2020, 7:16 p.m. UTC | #2
Am 27.10.20 um 09:59 schrieb Efraim Flashner:
> Assuming this doesn't break denlive, kdevelop or lxqt it looks good to
> me. Although I haven't tried building it.

Thanks for the quick response.

All three packages still build and kdenlive and kdevelop both start.
Pushed as fc6bced6c5d325aeb8c748464cf9addfd61c71c8
diff mbox series

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index e53817db37..cba4164a9f 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -415,14 +415,14 @@  applications from the command line.")
 (define-public kdecoration
   (package
     (name "kdecoration")
-    (version "5.18.5")
+    (version "5.19.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://kde/stable/plasma/" version
                                   "/kdecoration-" version ".tar.xz"))
               (sha256
                (base32
-                "1j59axgpdbj7nlg06h5gb0pix3s3nll32k6s2f88vc1cbwj5d67h"))))
+                "0pn8n7zyb0adzjnn92vmbcf7pmpss60k9k1rk5llamj016xzfgnf"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)))
@@ -643,14 +643,14 @@  automatic screen handling.")
 (define-public kscreenlocker
   (package
     (name "kscreenlocker")
-    (version "5.18.5")
+    (version "5.19.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://kde/stable/plasma/" version
                                   "/kscreenlocker-" version ".tar.xz"))
               (sha256
                (base32
-                "1lhq9rxafbbxwpwzq8m25xi9hgcdfdfwl8hafqhygzp14z89q9ml"))))
+                "1fd5sqaqx9kj3kr0bgxpllhcm5arf8bc9pkpd9yk9c8xjy0j0fxi"))))
     (build-system qt-build-system)
     (arguments
      `(#:phases
@@ -1062,14 +1062,14 @@  and prints it in a X window.")
 (define-public libkscreen
   (package
     (name "libkscreen")
-    (version "5.18.5")
+    (version "5.19.5")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://kde/stable/plasma/" version "/"
                            name "-" version ".tar.xz"))
        (sha256
-        (base32 "0z18djlfrj510dz3r2n8qx6fswdbp2qmhg5y3bn00hij02832qm9"))))
+        (base32 "0rf1pm0yyc069f4n5s9ipdx4glzfr9zvv5cbrmn4q9i4v6z1qd8i"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -1092,15 +1092,14 @@  basic needs and easy to configure for those who want special setups.")
 (define-public libksysguard
   (package
     (name "libksysguard")
-    (version "5.18.5")
+    (version "5.19.5")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://kde//stable/plasma/" version
                            "/libksysguard-" version ".tar.xz"))
        (sha256
-        (base32
-         "02s40ahqp4r9amjshdf0dhw9hdggvica2jl426i4d9b950507myl"))))
+        (base32 "1kd0h3p8bf9k5pqp0frhr81pa0yyrpkckg9zznirk9p1v88v7bfq"))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))
@@ -1113,11 +1112,14 @@  basic needs and easy to configure for those who want special setups.")
        ("kcompletion" ,kcompletion)
        ("kconfig" ,kconfig)
        ("kcoreaddons" ,kcoreaddons)
+       ("kdeclarative" ,kdeclarative)
        ("kglobalaccel" ,kglobalaccel)
        ("kio" ,kio)
+       ("knewstuff" ,knewstuff)
        ("kwidgetsaddons" ,kwidgetsaddons)
        ("kservice" ,kservice)
        ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)
        ("qtscript" ,qtscript)
        ("qtwebkit" ,qtwebkit)
        ("qtx11extras" ,qtx11extras)