[bug#77742] gnu: Add sbcl-stumpwm-rofi.
Commit Message
* gnu/packages/wm.scm (sbcl-stumpwm-rofi): New variable.
Change-Id: I95dfa85ac995f72b5cc6eead6a7cb0775c99ca83
---
gnu/packages/wm.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
base-commit: 2934de1447f87b361608ef3a2a756b8a5d2f42e6
Comments
Patch applied as 740c6cb279668a3edbd935c3f9a1f3031a69e43f.
Thanks.
@@ -2907,6 +2907,37 @@ (define-public sbcl-stumpwm-pass
password-store into StumpWM.")
(license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+(define-public sbcl-stumpwm-rofi
+ (package
+ (name "sbcl-stumpwm-rofi")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Junker/stumpwm-rofi")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1s0sri19rv6dshwm49djgbfc0zajl63gr1rg8xl762chlj28h1ir"))))
+ (arguments
+ '(#:asd-systems '("rofi")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-rofi-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "rofi.lisp"
+ (("rofi -dmenu")
+ (string-append (search-input-file inputs "/bin/rofi")
+ " -dmenu"))))))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list stumpwm rofi))
+ (home-page "https://github.com/Junker/stumpwm-rofi")
+ (synopsis "Rofi module for StumpWM")
+ (description "Rofi integration for StumpWM")
+ (license license:gpl3+)))
+
(define-public sbcl-stumpwm-globalwindows
(package
(inherit stumpwm-contrib)