diff mbox series

[bug#70512] gnu: php: Update to 8.3.6.

Message ID b67afb3d14e2b7d865fd04efc23faea2014660b8.1713778996.git.w@wmeyer.eu
State New
Headers show
Series [bug#70512] gnu: php: Update to 8.3.6. | expand

Commit Message

Wilko Meyer April 22, 2024, 9:43 a.m. UTC
* gnu/packages/php.scm (php): Update to 8.3.6.

Change-Id: I8f173558fc4098d6d72b42724e5e106d7dabb62a
---
Hi Guix,

This patch updates PHP, the new version successfully builds and runs locally:

~/devel/guix [env]$ php --version
PHP 8.3.6 (cli) (built: Jan  1 1970 00:00:01) (NTS)

I had to skip two failing tests, one which seems to be
unreliable/flaky according to reports[0], another one which seems to
address a Windows only bug[1]. Haven't spend too much time investigating
these further/trying to find ways of fixing at least the non-windows
one; maybe will do so if time isn't as limited as it is right now.

[0]: https://github.com/php/php-src/issues/11401
[1]: https://bugs.php.net/bug.php?id=74589

 gnu/packages/php.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)


base-commit: a1d711c92e119f6b5b8e99a620cdba92a4ca3bfb
prerequisite-patch-id: 0f9de37cc18b327c988be58ed9280e06b73172d3

Comments

Christopher Baines April 26, 2024, 4:33 p.m. UTC | #1
Wilko Meyer <w@wmeyer.eu> writes:

> * gnu/packages/php.scm (php): Update to 8.3.6.
>
> Change-Id: I8f173558fc4098d6d72b42724e5e106d7dabb62a
> ---
> Hi Guix,
>
> This patch updates PHP, the new version successfully builds and runs locally:
>
> ~/devel/guix [env]$ php --version
> PHP 8.3.6 (cli) (built: Jan  1 1970 00:00:01) (NTS)
>
> I had to skip two failing tests, one which seems to be
> unreliable/flaky according to reports[0], another one which seems to
> address a Windows only bug[1]. Haven't spend too much time investigating
> these further/trying to find ways of fixing at least the non-windows
> one; maybe will do so if time isn't as limited as it is right now.
>
> [0]: https://github.com/php/php-src/issues/11401
> [1]: https://bugs.php.net/bug.php?id=74589
>
>  gnu/packages/php.scm | 9 ++++++---
>  1 file changed, 6 insertions(+), 3 deletions(-)

This looks good to me, I've pushed the patch to master as
d2a1a4efad4f1ee5b92320bdd7146411184652f9.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 8419ac033b..72201770c7 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -62,7 +62,7 @@  (define-module (gnu packages php)
 (define-public php
   (package
     (name "php")
-    (version "8.2.13")
+    (version "8.3.6")
     (home-page "https://www.php.net/")
     (source (origin
               (method url-fetch)
@@ -70,7 +70,7 @@  (define-public php
                                   "php-" version ".tar.xz"))
               (sha256
                (base32
-                "0js5bm8r3kngsgmxhyr681vrpl4gib3318k8428pigqp06hvna96"))
+                "1bjygxjaqmvccyk4ic3lrca5j34f0pjb6f1ldmi9gbr345mkij2k"))
               (modules '((guix build utils)))
               (snippet
                '(with-directory-excursion "ext"
@@ -278,7 +278,10 @@  (define-public php
                          ;; PCRE with/without JIT gives different result
                          "ext/pcre/tests/gh11374.phpt"
                          "ext/pcre/tests/gh11956.phpt"
-
+                         ;; reported bug only seems to affect windows
+                         "ext/standard/tests/directory/bug74589_utf8.phpt"
+                         ;; this test seems to be unreliable/flaky
+                         "sapi/cli/tests/php_cli_server_pdeathsig.phpt"
                          ;; This test fails on most architectures.
                          "sapi/cli/tests/upload_2G.phpt"))