diff mbox series

[bug#74495,01/16] gnu: Add go-github-com-atotto-clipboard.

Message ID b653e021654bb28edea920ae26d808fad5452c8e.1732386154.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-noahgorstein-jqp. | expand

Commit Message

Artyom V. Poptsov Nov. 23, 2024, 6:28 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-atotto-clipboard): New variable.

Change-Id: I4a871983f564034045f4b2ba77f2453cfce5cb2b
---
 gnu/packages/golang-xyz.scm | 35 ++++++++++++++++++++++++++++++++++-
 1 file changed, 34 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 177ab8a20f..b050c285f3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -85,7 +85,9 @@  (define-module (gnu packages golang-xyz)
   #:use-module (gnu packages golang-maths)
   #:use-module (gnu packages golang-web)
   #:use-module (gnu packages linux)
-  #:use-module (gnu packages specifications))
+  #:use-module (gnu packages specifications)
+  #:use-module (gnu packages xdisorg)
+  #:use-module (gnu packages xorg))
 
 ;;; Commentary:
 ;;;
@@ -5735,6 +5737,37 @@  (define-public go-github-com-multiformats-go-varint
 varints.")
     (license license:expat)))
 
+(define-public go-github-com-atotto-clipboard
+  (package
+    (name "go-github-com-atotto-clipboard")
+    (version "0.1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/atotto/clipboard")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ycd8zkgsq9iil9svhlwvhcqwcd7vik73nf8rnyfnn10gpjx97k5"))))
+    (build-system go-build-system)
+    (native-inputs (list xorg-server-for-tests))
+    (propagated-inputs (list xclip))
+    (arguments
+     (list
+      #:import-path "github.com/atotto/clipboard"
+      #:phases #~(modify-phases %standard-phases
+                   (add-before 'check 'start-xorg-server
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       ;; The test suite requires a running X server.
+                       (system "Xvfb :1 &")
+                       (setenv "DISPLAY" ":1"))))))
+    (home-page "https://github.com/atotto/clipboard")
+    (synopsis "Clipboard for Golang")
+    (description
+     "@code{clipboard} provides copying and pasting to the clipboard for Go.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-nats-io-nats-go
   (package
     (name "go-github-com-nats-io-nats-go")