diff mbox series

[bug#74379] gnu: libx86emu: Fix build.

Message ID b647d3a149c94ee84cde1af3af7442633afa3416.1731745518.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#74379] gnu: libx86emu: Fix build. | expand

Commit Message

Artyom V. Poptsov Nov. 16, 2024, 8:25 a.m. UTC
* gnu/packages/virtualization.scm (libx86emu): Fix build.
[arguments]: Add extra "make-x86test" phase to make sure that "x86test" exists
before running the parallel tests.

Change-Id: Iad8d3fca6d4c04f6df9eba88e33e47324f160083
---
 gnu/packages/virtualization.scm | 7 +++++++
 1 file changed, 7 insertions(+)


base-commit: 3e8d3d80f41e016cdfe80e488a78c2351c94fef8

Comments

Artyom V. Poptsov Nov. 16, 2024, 10:20 a.m. UTC | #1
Merged to the "master" branch as
b647d3a149c94ee84cde1af3af7442633afa3416.

- avp
diff mbox series

Patch

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 5c9461745c..b76180c3c6 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
 ;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
 ;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -732,6 +733,12 @@  (define-public libx86emu
                            (string-append "LIBDIR = " lib "\n"))
                           (("/usr/include")
                            include)))))
+                  ;; XXX: "make -C test" fails because it cannot find "x86test"
+                  ;; executable due to parallel tests.  So we need to make sure that
+                  ;; this file is built before running the tests.
+                  (add-before 'check 'make-x86test
+                    (lambda _
+                      (invoke "make" "-C" "test" "x86test")))
                   (delete 'configure)))) ;no configure script
     (native-inputs (list nasm perl))
     (synopsis "Library for x86 emulation")