diff mbox series

[bug#66452] gnu: emacs-mastodon: Update to 1.0.6.

Message ID b64705f0bd856f46bff376faba513a1184f18287.1696967572.git.csantosb@inventati.org
State New
Headers show
Series [bug#66452] gnu: emacs-mastodon: Update to 1.0.6. | expand

Commit Message

Cayetano Santos Oct. 10, 2023, 7:52 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.6.
---
 gnu/packages/emacs-xyz.scm | 65 ++++++++++++++++++--------------------
 1 file changed, 31 insertions(+), 34 deletions(-)


base-commit: fc6c910f797ea232f6019c4ca5dbd105f78928df

Comments

vasilii.smirnov--- via Guix-patches" via Oct. 17, 2023, 8:34 a.m. UTC | #1
>mar. 10 oct. 2023 at 19:55, help-debbugs@gnu.org (GNU bug Tracking System) wrote:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 66452@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cf1542955c..24912f0e41 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32827,40 +32827,37 @@  (define-public emacs-wc-mode
     (license license:gpl3+)))
 
 (define-public emacs-mastodon
-  ;; No release in ~1 year, hence this snapshot.
-  (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
-        (revision "1"))
-    (package
-      (name "emacs-mastodon")
-      (version (git-version "1.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://codeberg.org/martianh/mastodon.el")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
-      (build-system emacs-build-system)
-      (arguments
-       (list #:phases
-             #~(modify-phases %standard-phases
-                 ;; Move the source files to the top level, which is included in
-                 ;; the EMACSLOADPATH.
-                 (add-after 'unpack 'move-source-files
-                   (lambda _
-                     (let ((el-files (find-files "./lisp" ".*\\.el$")))
-                       (for-each (lambda (f)
-                                   (rename-file f (basename f)))
-                                 el-files)))))))
-      (propagated-inputs
-       (list emacs-request emacs-ts emacs-persist))
-      (home-page "https://codeberg.org/martianh/mastodon.el")
-      (synopsis "Emacs client for Mastodon")
-      (description "@code{mastodon.el} is an Emacs client for Mastodon, the
-federated microblogging social network.")
-	  (license license:gpl3+))))
+  (package
+    (name "emacs-mastodon")
+    (version "1.0.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://codeberg.org/martianh/mastodon.el")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1z5lmzxhindxa0f6qi6z361k9smqcz68alr6w6jbmwg279qmk8jj"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               ;; Move the source files to the top level, which is included in
+               ;; the EMACSLOADPATH.
+               (add-after 'unpack 'move-source-files
+                 (lambda _
+                   (let ((el-files (find-files "./lisp" ".*\\.el$")))
+                     (for-each (lambda (f)
+                                 (rename-file f (basename f)))
+                               el-files)))))))
+    (propagated-inputs
+     (list emacs-request emacs-ts emacs-persist))
+    (home-page "https://codeberg.org/martianh/mastodon.el")
+    (synopsis "Emacs client for Mastodon")
+    (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+  federated microblogging social network.")
+    (license license:gpl3+)))
 
 (define-public emacs-ebdb
   (package