[bug#78550,2/2] gnu: Add go-mtpfs.
Commit Message
* gnu/packages/libusb.scm (go-mtpfs): New variable.
Change-Id: I08e5fa08eb1844efa3294be5d2006118c25eb186
---
gnu/packages/libusb.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -52,6 +52,7 @@ (define-module (gnu packages libusb)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
@@ -237,6 +238,36 @@ (define-public go-github-com-hanwen-usb
(description "These are CGO bindings for libusb")
(license license:bsd-3))))
+(define-public go-mtpfs
+ (package
+ (name "go-mtpfs")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hanwen/go-mtpfs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1k77zglpgb5424hpnc270yj27x1rb2wp4b8y5xchd6h8ygrw2mqx"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:import-path "github.com/hanwen/go-mtpfs"))
+ (inputs (list libusb))
+ (native-inputs (list pkg-config))
+ (propagated-inputs (list go-github-com-hanwen-usb
+ go-github-com-hanwen-go-fuse-v2
+ go-github-com-hanwen-go-fuse))
+ (home-page "https://github.com/hanwen/go-mtpfs")
+ (synopsis "Mount MTP devices as a filesystem")
+ (description
+ "Go-mtpfs is a simple FUSE filesystem for mounting Android devices as a MTP
+device.")
+ (license license:bsd-3)))
+
(define-public java-usb4java
(package
(name "java-usb4java")