diff mbox series

[bug#72963,go-team,v2,09/22] gnu: Add go-github-com-vito-midterm.

Message ID b6368e5c0e6bcb28469e471058336563b2e408c0.1733231503.git.herman@rimm.ee
State New
Headers show
Series [bug#72963,go-team,v2,01/22] gnu: Add go-github-com-buildkite-shellwords. | expand

Commit Message

Herman Rimm Dec. 3, 2024, 1:14 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-vito-midterm): Add
variable.
---
 gnu/packages/golang-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 908b0be7e2..ebfb18c14c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -7852,6 +7852,36 @@  (define-public go-github-com-tkuchiki-go-timezone
 @end itemize")
     (license license:expat)))
 
+(define-public go-github-com-vito-midterm
+  (package
+    (name "go-github-com-vito-midterm")
+    (version "0.1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vito/midterm")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0bvgw84750xfpm89hrab7pzfv1d5dy94igiqwzk5ivy4yca90ipw"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "github.com/vito/midterm"))
+    (propagated-inputs (list go-golang-org-x-term
+                             go-github-com-stretchr-testify
+                             go-github-com-sebdah-goldie-v2
+                             go-github-com-muesli-termenv
+                             go-github-com-creack-pty
+                             go-github-com-charmbracelet-bubbletea))
+    (home-page "https://github.com/vito/midterm")
+    (synopsis "In-memory terminal emulator")
+    (description
+     "This package implements an in-memory terminal emulator, designed
+to be used as a component within a larger application for displaying
+logs, running interactive shells, or rendering terminal output.")
+    (license license:expat)))
+
 (define-public go-github-com-vitrun-qart
   (let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
         (revision "0"))