diff mbox series

[bug#69102] Update llama-cpp hashes to latest version and add new script names

Message ID b625fec73623b70fe970180b1435cb4f2b6396e9.1707838332.git.john@fremlin.org
State New
Headers show
Series [bug#69102] Update llama-cpp hashes to latest version and add new script names | expand

Commit Message

John Fremlin Feb. 13, 2024, 3:32 p.m. UTC
Change-Id: I9f5474606dd01be73fbc50813250991e9d248d85
---
 gnu/packages/machine-learning.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)


base-commit: ffc7650c11fd7c4b9f7b4894f8e0a451e0e49063

Comments

Ludovic Courtès March 2, 2024, 4:09 p.m. UTC | #1
Hi,

John Fremlin <john@fremlin.org> skribis:

>  (define-public llama-cpp
> -  (let ((commit "f31b5397143009d682db90fd2a6cde83f1ef00eb")
> +  (let ((commit "03bf161eb6dea6400ee49c6dc6b69bdcfa9fd3fc")
>          (revision "0"))

I bumped ‘revision’, tweaked the commit log according to our
conventions, and applied.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 2e20872555..53e152a88f 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -522,7 +522,7 @@  (define-public guile-aiscm-next
   (deprecated-package "guile-aiscm-next" guile-aiscm))
 
 (define-public llama-cpp
-  (let ((commit "f31b5397143009d682db90fd2a6cde83f1ef00eb")
+  (let ((commit "03bf161eb6dea6400ee49c6dc6b69bdcfa9fd3fc")
         (revision "0"))
     (package
       (name "llama-cpp")
@@ -532,10 +532,10 @@  (define-public llama-cpp
          (method git-fetch)
          (uri (git-reference
                (url "https://github.com/ggerganov/llama.cpp")
-               (commit (string-append "master-" (string-take commit 7)))))
+               (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "0ys6n53n032zq1ll9f3vgxk8sw0qq7x3fi7awsyy13adzp3hn08p"))))
+          (base32 "1ag1jash84hasz10h0piw72a8ginm8kzvhihbzzljz96gq2kjm88"))))
       (build-system cmake-build-system)
       (arguments
        (list
@@ -562,8 +562,10 @@  (define-public llama-cpp
                                       (get-string-all input))))))
                       (chmod (string-append bin script) #o555)))
                   (mkdir-p bin)
-                  (make-script "convert-pth-to-ggml")
+                  (make-script "convert-hf-to-gguf")
+                  (make-script "convert-llama-ggml-to-gguf")
                   (make-script "convert-lora-to-ggml")
+                  (make-script "convert-persimmon-to-gguf")
                   (make-script "convert"))))
             (add-after 'install-python-scripts 'wrap-python-scripts
               (assoc-ref python:%standard-phases 'wrap))