diff mbox series

[bug#64592,1/2] gnu: node-lts: Simplify snippet.

Message ID b5e817925299a377b7948cb7f683126ed2f57ff6.1689237014.git.rekado@elephly.net
State New
Headers show
Series [bug#64592,1/2] gnu: node-lts: Simplify snippet. | expand

Commit Message

Ricardo Wurmus July 13, 2023, 8:30 a.m. UTC
* gnu/packages/node.scm (node-lts)[source]: Remove quasiquote, trailing #T,
and IF with explicit booleans.
---
 gnu/packages/node.scm | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)


base-commit: 2794caed7c813f2ec4249236de36eaccafee8361

Comments

宋文武 July 21, 2023, 12:28 p.m. UTC | #1
Pushed as 5dc2a88f99e2e448f7e9ca842a4a0d072a8f8f20, close issue...
diff mbox series

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 7695614b3a..c0bb4f2342 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -7,7 +7,7 @@ 
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018-2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020, 2021 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020, 2023 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021, 2022 Philip McGrath <philip@philipmcgrath.com>
@@ -748,13 +748,12 @@  (define-public node-lts
                 "0vcc132z7lkxnw5clmiz6sp6ccmw35pyb69hczphrig5frfmqkva"))
               (modules '((guix build utils)))
               (snippet
-               `(begin
+               '(begin
                   ;; openssl.cnf is required for build.
                   (for-each delete-file-recursively
                             (find-files "deps/openssl"
                                         (lambda (file stat)
-                                          (if (string-contains file "nodejs-openssl.cnf")
-                                              #f #t))))
+                                          (not (string-contains file "nodejs-openssl.cnf")))))
                   ;; Remove bundled software, where possible
                   (for-each delete-file-recursively
                             '("deps/cares"
@@ -764,8 +763,7 @@  (define-public node-lts
                   (substitute* "Makefile"
                     ;; Remove references to bundled software.
                     (("deps/uv/uv.gyp") "")
-                    (("deps/zlib/zlib.gyp") ""))
-                  #t))))
+                    (("deps/zlib/zlib.gyp") ""))))))
     (arguments
      (substitute-keyword-arguments (package-arguments node)
        ((#:configure-flags configure-flags)