diff mbox series

[bug#71035,2/2] gnu: opensc: Switch to new package style.

Message ID b5ddc960fd678ce1d5cfcd10e503333ff5d43f5a.1716031956.git.timotej.lazar@araneo.si
State New
Headers show
Series Update opensc | expand

Commit Message

Timotej Lazar May 18, 2024, 11:39 a.m. UTC
* gnu/packages/security-token.scm (opensc)[arguments]: Use g-exps.

Change-Id: I3e59323deb804ba98669d51771ccfa05a92723e3
---
 gnu/packages/security-token.scm | 27 +++++++++++++--------------
 1 file changed, 13 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index a376db3bc0..00426d6d99 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -366,20 +366,19 @@  (define-public opensc
                 "0yxk97aj29pybvya6r9ix9xh00hdzcfrc2lcns4vb3kwpplamjr3"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; By setting an absolute path here, we arrange for OpenSC to
-         ;; successfully dlopen libpcsclite.so.1 by default.  The user can
-         ;; still override this if they want to, by specifying a custom OpenSC
-         ;; configuration file at runtime.
-         (add-after 'unpack 'set-default-libpcsclite.so.1-path
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((libpcsclite (search-input-file inputs
-                                                   "/lib/libpcsclite.so.1")))
-               (substitute* "configure"
-                 (("DEFAULT_PCSC_PROVIDER=\"libpcsclite\\.so\\.1\"")
-                  (string-append
-                   "DEFAULT_PCSC_PROVIDER=\"" libpcsclite "\"")))))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; By setting an absolute path here, we arrange for OpenSC to
+          ;; successfully dlopen libpcsclite.so.1 by default.  The user can
+          ;; still override this if they want to, by specifying a custom OpenSC
+          ;; configuration file at runtime.
+          (add-after 'unpack 'set-default-libpcsclite.so.1-path
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((libpcsclite (search-input-file inputs "/lib/libpcsclite.so.1")))
+                (substitute* "configure"
+                  (("DEFAULT_PCSC_PROVIDER=\"libpcsclite\\.so\\.1\"")
+                   (string-append "DEFAULT_PCSC_PROVIDER=\"" libpcsclite "\"")))))))))
     (inputs
      (list readline openssl-1.1 pcsc-lite ccid))
     (native-inputs