diff mbox series

[bug#72096,v--thread=shallow,2/2] gnu: borg: Update to 1.4.0.

Message ID b59cf396b7af05b7418427ae2f9bdd35287ca3cc.1720894469.git.leo@famulari.name
State New
Headers show
Series [bug#72096,v--thread=shallow,1/2] gnu: xxHash: Update to 0.8.2. | expand

Commit Message

Leo Famulari July 13, 2024, 6:14 p.m. UTC
* gnu/packages/backup.scm (borg): Update to 1.4.0.
[source]: Remove obsolete snippet components.
[arguments]: Export a newly required environment variable in the 'set-env'
phase. Adjust the custom 'install-doc' phase to install miscellaneous
documentation into a directory named after the package name and version.

Change-Id: I688bb4e6c67506226418b6b4a47595f2a10c10ae
---
 gnu/packages/backup.scm | 18 ++++++++----------
 1 file changed, 8 insertions(+), 10 deletions(-)

Comments

Leo Famulari July 24, 2024, 9:57 p.m. UTC | #1
On Sat, Jul 13, 2024 at 02:14:29PM -0400, Leo Famulari wrote:
> * gnu/packages/backup.scm (borg): Update to 1.4.0.
> [source]: Remove obsolete snippet components.
> [arguments]: Export a newly required environment variable in the 'set-env'
> phase. Adjust the custom 'install-doc' phase to install miscellaneous
> documentation into a directory named after the package name and version.

Pushed as ff4e3b4b0e46207518dc6a93f1ec8b05b543c439
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 637a873fbf..fbad03ebbc 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -675,14 +675,13 @@  (define-public libchop
 (define-public borg
   (package
     (name "borg")
-    (version "1.2.8")
+    (version "1.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "borgbackup" version))
        (sha256
-        (base32 "1aplj54x6hcyg3mnzscnwi07npy7nrws2246ss25ax6bsaq257fk"))
-       (modules '((guix build utils)))
+        (base32 "0agdyrmj7yy2vn0qghcpq458v9d09q9jvzzrszz6dyj3aqalak65"))
        (snippet
         #~(begin
             ;; Delete files generated by Cython.  We used to have a regex that
@@ -701,11 +700,7 @@  (define-public borg
                         "src/borg/platform/linux.c"
                         "src/borg/platform/posix.c"
                         "src/borg/platform/syncfilerange.c"
-                        "src/borg/platform/windows.c"))
-            ;; Remove bundled shared libraries.
-            (with-directory-excursion "src/borg/algorithms"
-              (for-each delete-file-recursively
-                        (list "lz4" "xxh64" "zstd")))))))
+                        "src/borg/platform/windows.c"))))))
     (build-system python-build-system)
     (arguments
      (list
@@ -716,10 +711,12 @@  (define-public borg
       #~(modify-phases %standard-phases
           (add-after 'unpack 'set-env
             (lambda* (#:key inputs #:allow-other-keys)
-              (let ((openssl #$(this-package-input "openssl"))
+              (let ((acl #$(this-package-input "acl"))
+                    (openssl #$(this-package-input "openssl"))
                     (lz4 #$(this-package-input "lz4"))
                     (xxhash #$(this-package-input "xxhash"))
                     (zstd #$(this-package-input "zstd")))
+                (setenv "BORG_LIBACL_PREFIX" acl)
                 (setenv "BORG_OPENSSL_PREFIX" openssl)
                 (setenv "BORG_LIBLZ4_PREFIX" lz4)
                 (setenv "BORG_LIBXXHASH_PREFIX" xxhash)
@@ -756,7 +753,8 @@  (define-public borg
           (add-after 'install 'install-doc
             (lambda _
               (let ((man (string-append #$output "/share/man/man1"))
-                    (misc (string-append #$output "/share/borg/misc")))
+                    (misc (string-append #$output "/share/doc/borg-"
+                                         #$(package-version this-package))))
                 (for-each (cut install-file <> misc)
                           '("docs/misc/create_chunker-params.txt"
                             "docs/misc/borg-data-flow.png"