[bug#75167,gnome-team,6/6] gnu: gnome-builder: Update to 47.2.

Message ID b59cd33a161981c567284d1b9e3b6e16e2588c30.1735418244.git.liliana.prikler@gmail.com
State New
Headers
Series Update GNOME Builder to 47.2 |

Commit Message

Liliana Marie Prikler Dec. 28, 2024, 8:35 p.m. UTC
  * gnu/packages/gnome.scm (gnome-builder): Update to 47.2.
[#:phases]: Drop ‘patch-source’:
[inputs]: Add gom and libspelling.  Replace libpeas with libpeas-2.
[native-inputs]: Add gcc-14.
---
 gnu/packages/gnome.scm | 20 +++++++++-----------
 1 file changed, 9 insertions(+), 11 deletions(-)
  

Comments

Maxim Cournoyer Dec. 29, 2024, 4:38 a.m. UTC | #1
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gnome.scm (gnome-builder): Update to 47.2.
> [#:phases]: Drop ‘patch-source’:
> [inputs]: Add gom and libspelling.  Replace libpeas with libpeas-2.
> [native-inputs]: Add gcc-14.

[...]

>             gspell
>             gtk
> +           gom

Not added in alphabetical order.

>             json-glib
>             jsonrpc-glib
>             libadwaita
> @@ -13721,9 +13714,10 @@ (define-public gnome-builder
>             libdex
>             libgit2-glib
>             libpanel
> -           libpeas
> +           libpeas-2
>             libportal
>             libsoup
> +           libspelling
>             llvm
>             libostree
>             python
> @@ -13738,6 +13732,10 @@ (define-public gnome-builder
>       (list desktop-file-utils           ;for desktop-file-validate
>             `(,glib "bin")
>             gettext-minimal
> +           ;; GCC 14 seems to be required to not end up in a compilation
> +           ;; failure.
> +           ;; See <https://gitlab.gnome.org/GNOME/gnome-builder/-/issues/2176>.
> +           gcc-14

Alternatively, there's this small patch:
https://gitlab.gnome.org/-/project/426/uploads/3595cbe09fb9dd41d558a317251ca356/gdkrgba.patch;
perhaps could be applied in a substitute phase.  Not sure what is best here,
I'll leave it to your judgement.
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f3568350f79..95318a85312 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13649,7 +13649,7 @@  (define-public libspelling
 (define-public gnome-builder
   (package
     (name "gnome-builder")
-    (version "44.2")
+    (version "47.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -13657,7 +13657,7 @@  (define-public gnome-builder
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1c192xzjv5hsbp1p3wil595810k49kgmf5a7lwf260izip3qk9ng"))))
+                "15dlm6zvq54djx6h1z3jg21fw4v21dwh7i9db9k367nd8wybk1s6"))))
     (build-system meson-build-system)
     (arguments
      (list
@@ -13665,14 +13665,6 @@  (define-public gnome-builder
       #:configure-flags #~(list "-Dnetwork_tests=false" "-Ddocs=true")
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'patch-source
-            (lambda _
-              ;; With Gnome 4.14, GtkStackPage has an autoptr already, so it'd
-              ;; get redefined.  Drop this phase when updating gnome-builder to
-              ;; 46.0 or newer.  See also
-              ;; <https://gitlab.gnome.org/GNOME/gnome-builder/-/commit/7aaaecefc2ea8a37eaeae8b4d726d119d4eb8fa3>
-              (substitute* "src/libide/tweaks/ide-tweaks-window.c"
-                (("G_DEFINE_AUTOPTR_CLEANUP_FUNC \\(GtkStackPage, .*\\)") ""))))
           (add-after 'unpack 'patch-meson
             (lambda* (#:key inputs #:allow-other-keys)
               (substitute* "meson.build"
@@ -13714,6 +13706,7 @@  (define-public gnome-builder
            flatpak
            gspell
            gtk
+           gom
            json-glib
            jsonrpc-glib
            libadwaita
@@ -13721,9 +13714,10 @@  (define-public gnome-builder
            libdex
            libgit2-glib
            libpanel
-           libpeas
+           libpeas-2
            libportal
            libsoup
+           libspelling
            llvm
            libostree
            python
@@ -13738,6 +13732,10 @@  (define-public gnome-builder
      (list desktop-file-utils           ;for desktop-file-validate
            `(,glib "bin")
            gettext-minimal
+           ;; GCC 14 seems to be required to not end up in a compilation
+           ;; failure.
+           ;; See <https://gitlab.gnome.org/GNOME/gnome-builder/-/issues/2176>.
+           gcc-14
            gi-docgen
            pkg-config
            python                       ;for meson scripts