diff mbox series

[bug#71418] gnu: pinentry-tty: Update to 1.3.0.

Message ID b571957661a0b8b2e38390bd8652ffa9d8731305.1717785250.git.ashish.is@lostca.se
State New
Headers show
Series [bug#71418] gnu: pinentry-tty: Update to 1.3.0. | expand

Commit Message

sirgazil--- via Guix-patches via June 7, 2024, 6:34 p.m. UTC
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/gnupg.scm (pinentry-tty): Update to 1.3.0

* gnu/packages/gnupg.scm (pinentry-qt): Update to 1.3.0
  [inputs] also prepend qtbase for Qt6 support

Change-Id: I866bef0538fd5068e9e82d10a9e87aa1515826a5
---
 gnu/packages/gnupg.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)


base-commit: 580d77d0fb12448ef1621699cc0c56e787e2aadb

Comments

Maxim Cournoyer June 24, 2024, 2:28 a.m. UTC | #1
Hello,

ashish.is@lostca.se writes:

> From: Ashish SHUKLA <ashish.is@lostca.se>
>
> * gnu/packages/gnupg.scm (pinentry-tty): Update to 1.3.0
>
> * gnu/packages/gnupg.scm (pinentry-qt): Update to 1.3.0
>   [inputs] also prepend qtbase for Qt6 support

Perhaps we can target only Qt6?  It seems overly big in terms of closure
size to target two versions of Qt at the same time.

What do you think?
Ashish June 24, 2024, 3:38 a.m. UTC | #2
On Mon Jun 24, 2024 at 4:28 AM CEST, Maxim Cournoyer wrote:
> Hello,
>
> ashish.is@lostca.se writes:
>
> > From: Ashish SHUKLA <ashish.is@lostca.se>
> >
> > * gnu/packages/gnupg.scm (pinentry-tty): Update to 1.3.0
> >
> > * gnu/packages/gnupg.scm (pinentry-qt): Update to 1.3.0
> >   [inputs] also prepend qtbase for Qt6 support
>
> Perhaps we can target only Qt6?  It seems overly big in terms of closure
> size to target two versions of Qt at the same time.

Sure, that sounds fair. I will submit a commit shortly.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index e7c583a266..390a8dbb1e 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -839,14 +839,14 @@  (define-public signing-party
 (define-public pinentry-tty
   (package
     (name "pinentry-tty")
-    (version "1.2.1")
+    (version "1.3.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnupg/pinentry/pinentry-"
                                   version ".tar.bz2"))
               (sha256
                (base32
-                "0rs019acfj7sr4pvc847nk42v5mba9ixqmd98nwqy8w5b9g1hyj5"))))
+                "1pllchqwl6wq4q4dpsarcm9m2cwjb733p6irxpyz55vmdqidag4v"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--enable-pinentry-tty")))
@@ -911,7 +911,7 @@  (define-public pinentry-qt
      `(#:configure-flags '("--enable-fallback-curses")))
     (inputs
      (modify-inputs (package-inputs pinentry-tty)
-       (prepend qtbase-5)))
+       (prepend qtbase qtbase-5)))
   (description
    "Pinentry provides a console and a Qt GUI that allows users to enter a
 passphrase when @code{gpg} is run and needs it.")))