diff mbox series

[bug#63341] gnu: Add dummy linker for riscv64-elf.

Message ID b5368f5486fae706d430baa2229ab024d2830f9d.1683423060.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#63341] gnu: Add dummy linker for riscv64-elf. | expand

Commit Message

ashish.is--- via Guix-patches" via May 7, 2023, 1:31 a.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add case for riscv64-elf.
---
 gnu/packages/bootstrap.scm | 1 +
 1 file changed, 1 insertion(+)


base-commit: 5dcfe798f44753e18104541e83591cac6e053525

Comments

Efraim Flashner May 7, 2023, 8:43 a.m. UTC | #1
I have a couple of dummy *-elf systems I sometimes add and remove
depending on what I'm working on. What do you think about adding and
entry for ((string-suffix? "-elf" system) "no-ld.so") and being done
with these one-off targets?

On Sun, May 07, 2023 at 09:31:09AM +0800, iyzsong--- via Guix-patches via wrote:
> From: 宋文武 <iyzsong@member.fsf.org>
> 
> * gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add case for riscv64-elf.
> ---
>  gnu/packages/bootstrap.scm | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
> index 9a46f97c81..7acac9dea5 100644
> --- a/gnu/packages/bootstrap.scm
> +++ b/gnu/packages/bootstrap.scm
> @@ -333,6 +333,7 @@ (define* (glibc-dynamic-linker
>       ((string=? system "i686-mingw") "no-ld.so")
>       ((string=? system "x86_64-mingw") "no-ld.so")
>       ((string=? system "vc4-elf") "no-ld.so")
> +     ((string=? system "riscv64-elf") "no-ld.so")
>  
>       (else (error "dynamic linker name not known for this system"
>                    system)))))
> 
> base-commit: 5dcfe798f44753e18104541e83591cac6e053525
> -- 
> 2.39.2
>
diff mbox series

Patch

diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 9a46f97c81..7acac9dea5 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -333,6 +333,7 @@  (define* (glibc-dynamic-linker
      ((string=? system "i686-mingw") "no-ld.so")
      ((string=? system "x86_64-mingw") "no-ld.so")
      ((string=? system "vc4-elf") "no-ld.so")
+     ((string=? system "riscv64-elf") "no-ld.so")
 
      (else (error "dynamic linker name not known for this system"
                   system)))))