diff mbox series

[bug#38904] gnu: Add gnome-color-manager.

Message ID b4dadeae70aa6cbe57295432776a72a165a1a065.camel@disroot.org
State Accepted
Headers show
Series [bug#38904] gnu: Add gnome-color-manager. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 6, 2020, 5:53 a.m. UTC
Hello Danny!

> Trailing comments should have only one semicolon.
> 
> But better yet, since Guix packages build in a container, just start
> a display
> server yourself.
> 
> For examples, search for "Xvfb" in the Guix source code.

Thanks for the tip. Please find the revised patch attached with this
email.

Regards,
RG.

Comments

Danny Milosavljevic Jan. 9, 2020, 3:03 p.m. UTC | #1
Hi Raghav,

Some questions:

* Why is adwaita-icon-theme an input?

Some comments:

* xorg-server-for-tests should definitely be a native-input if it is used.
* desktop-file-utils should definitely be a native-input if it is used.
* itstool should definitely be a native-input if it is used.
Raghav Gururajan Jan. 9, 2020, 3:26 p.m. UTC | #2
Hi Danny!

> Some questions:
> 
> * Why is adwaita-icon-theme an input?

I believe this application retrives some information about graphical
properties of a-i-t from a-i-t package.

> Some comments:
> 
> * xorg-server-for-tests should definitely be a native-input if it is
> used.
> * desktop-file-utils should definitely be a native-input if it is
> used.
> * itstool should definitely be a native-input if it is used.

Yes, even I believe so. Would it be okay if I leave things as it is for
now? Because soon I will revising+testing all gnome packages one-by-
one, so I will be moving any unnessessary inputs to native-inputs. :-)

Regards,
RG.
Danny Milosavljevic Jan. 9, 2020, 5:02 p.m. UTC | #3
Hi Raghav,

On Thu, 09 Jan 2020 10:26:31 -0500
Raghav Gururajan <raghavgururajan@disroot.org> wrote:

> I believe this application retrives some information about graphical
> properties of a-i-t from a-i-t package.

To find out, I've removed it from the inputs and it built just fine and
gcm-viewer also started up fine.  What was the reason that you added it?

> Would it be okay if I leave things as it is for now?

You are free to leave it as is on your computer.  When merging it to
guix master there have to be some standards--otherwise master would be
perpetually broken.

In this specific case, some other packages in (gnu packages gnome) also have
adwaita-icon-theme as input.  Even when there is that input that is unused it
will not cause problems (however, it will also not do what you wanted
it to do--whatever that is).  Also, nothing depends on gnome-color-manager.
Therefore, applied to guix master as commit
29ae18db0578bbdbc0119703f7412fe91927e80e.

But really, having one specific theme (which is by definition a user-selectable
thing) as an input is weird.  Let's fix that everywhere eventually.
Raghav Gururajan Jan. 9, 2020, 5:31 p.m. UTC | #4
Hi Danny!

> To find out, I've removed it from the inputs and it built just fine
> and
> gcm-viewer also started up fine.  What was the reason that you added
> it?

The upstream mentioned it as a required dependency. Please view 
https://gitlab.gnome.org/GNOME/gnome-build-meta/blob/master/elements/core/gnome-color-manager.bst
.

> > Would it be okay if I leave things as it is for now?
> 
> You are free to leave it as is on your computer.  When merging it to
> guix master there have to be some standards--otherwise master would
> be
> perpetually broken.

I understand :-)

> In this specific case, some other packages in (gnu packages gnome)
> also have
> adwaita-icon-theme as input.  Even when there is that input that is
> unused it
> will not cause problems (however, it will also not do what you wanted
> it to do--whatever that is).  Also, nothing depends on gnome-color-
> manager.
> Therefore, applied to guix master as commit
> 29ae18db0578bbdbc0119703f7412fe91927e80e.

Thank you!

> But really, having one specific theme (which is by definition a user-
> selectable
> thing) as an input is weird.  Let's fix that everywhere eventually.

IIRC, gnome uses adwaita icon theme as default. I'll try look into what
can be done.

Regards,
RG.
diff mbox series

Patch

From 6b961ef1d336b9c8016432bf172713ae16568476 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Mon, 6 Jan 2020 00:51:19 -0500
Subject: [PATCH] gnu: Add gnome-color-manager.

* gnu/packages/gnome.scm (gnome-color-manager): New variable.
---
 gnu/packages/gnome.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6aed46b3b2..45a85d6035 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,59 @@  Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public gnome-color-manager
+  (package
+   (name "gnome-color-manager")
+   (version "3.32.0")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "1vpxa2zjz3lkq9ldjg0fl65db9s6b4kcs8nyaqfz3jygma7ifg3w"))))
+   (build-system meson-build-system)
+   (arguments
+    `(#:glib-or-gtk? #t
+      #:phases
+       (modify-phases %standard-phases
+        (add-before
+         'check 'pre-check
+         (lambda _
+           ;; Tests require a running X server.
+           (system "Xvfb :1 &")
+           (setenv "DISPLAY" ":1")
+           #t)))))
+   (native-inputs
+    `(("gettext" ,gettext-minimal)
+      ("glib:bin" ,glib "bin")
+      ("gtk+:bin" ,gtk+ "bin")
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("adwaita-icon-theme" ,adwaita-icon-theme)
+      ("appstream-glib" ,appstream-glib)
+      ("colord-gtk" ,colord-gtk)
+      ("desktop-file-utils" ,desktop-file-utils)
+      ("exiv2" ,exiv2)
+      ("gnome-desktop" ,gnome-desktop)
+      ("itstool" ,itstool)
+      ("libcanberra" ,libcanberra)
+      ("libexif" ,libexif)
+      ("libtiff" ,libtiff)
+      ("libxrandr" ,libxrandr)
+      ("libxtst" ,libxtst)
+      ("libxxf86vm" ,libxxf86vm)
+      ("vte" ,vte)
+      ("xorgproto" ,xorgproto)
+      ("xorg-server" ,xorg-server-for-tests)))
+   (synopsis "Color profile manager for the GNOME desktop")
+   (description "GNOME Color Manager is a session framework that makes
+it easy to manage, install and generate color profiles
+in the GNOME desktop.")
+   (home-page "https://gitlab.gnome.org/GNOME/gnome-color-manager")
+   (license license:gpl2)))
+
 (define-public gnome-online-miners
   (package
     (name "gnome-online-miners")
-- 
2.24.1