diff mbox series

[bug#74290,v2,13/40] gnu: gcc-13, gcc-14: Support being used as parent for gcc-static.

Message ID b4c0b38776c048869626bed8aefd4efb042cea11.1731427612.git.janneke@gnu.org
State New
Headers show
Series Add support for x86_64-gnu, aka the 64bit Hurd. | expand

Commit Message

Janneke Nieuwenhuizen Nov. 12, 2024, 4:25 p.m. UTC
* gnu/packages/gcc.scm (gcc-13)[arguments]: Use quasiquote instead of
g-expressions.
(gcc-14)[arguments]: Likewise.

Change-Id: I22269b31d49868effe967d46247b189ed9a9d394
---
 gnu/packages/gcc.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès Nov. 17, 2024, 4:49 p.m. UTC | #1
Hi!

Janneke Nieuwenhuizen <janneke@gnu.org> skribis:

> * gnu/packages/gcc.scm (gcc-13)[arguments]: Use quasiquote instead of
> g-expressions.
> (gcc-14)[arguments]: Likewise.
>
> Change-Id: I22269b31d49868effe967d46247b189ed9a9d394

[...]

> -           #~(modify-phases #$phases
> -               (delete 'patch-hurd-libpthread))
> +           `(modify-phases ,phases
> +              (delete 'patch-hurd-libpthread))

I think we should not do that as this undoes previous changes.

Instead, can we change whichever package expects to get an sexp here to
use gexps?

Ludo’.
Janneke Nieuwenhuizen Nov. 17, 2024, 6:27 p.m. UTC | #2
Ludovic Courtès writes:

> Hi!
>
> Janneke Nieuwenhuizen <janneke@gnu.org> skribis:
>
>> * gnu/packages/gcc.scm (gcc-13)[arguments]: Use quasiquote instead of
>> g-expressions.
>> (gcc-14)[arguments]: Likewise.
>>
>> Change-Id: I22269b31d49868effe967d46247b189ed9a9d394
>
> [...]
>
>> -           #~(modify-phases #$phases
>> -               (delete 'patch-hurd-libpthread))
>> +           `(modify-phases ,phases
>> +              (delete 'patch-hurd-libpthread))
>
> I think we should not do that as this undoes previous changes.
>
> Instead, can we change whichever package expects to get an sexp here to
> use gexps?

Hmm, how would that work?  The package that expects a sexp is
gcc-static.

If we update gcc-static to also use gexps we can no longer build any gcc
< 13 static?  Unless we update also update gcc-4.7, gcc-4.8, and those
in commencement.  Maybe (hopefully!) I'm missing something?

Greetings,
Janneke
Janneke Nieuwenhuizen Nov. 17, 2024, 6:46 p.m. UTC | #3
> Ludovic Courtès writes:

>> Janneke Nieuwenhuizen <janneke@gnu.org> skribis:
>>
>>> * gnu/packages/gcc.scm (gcc-13)[arguments]: Use quasiquote instead of
>>> g-expressions.
>>> (gcc-14)[arguments]: Likewise.
>>>
>>> Change-Id: I22269b31d49868effe967d46247b189ed9a9d394
>>
>> [...]
>>
>>> -           #~(modify-phases #$phases
>>> -               (delete 'patch-hurd-libpthread))
>>> +           `(modify-phases ,phases
>>> +              (delete 'patch-hurd-libpthread))
>>
>> I think we should not do that as this undoes previous changes.
>>
>> Instead, can we change whichever package expects to get an sexp here to
>> use gexps?
>
> Hmm, how would that work?  The package that expects a sexp is
> gcc-static.
>
> If we update gcc-static to also use gexps we can no longer build any gcc
> < 13 static?  Unless we update also update gcc-4.7, gcc-4.8, and those
> in commencement.  Maybe (hopefully!) I'm missing something?

I have upgraded %gcc-static in make-bootstrap to gcc-14, problem solved :)
hopefully.
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 850a14cb1c..befbbda027 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -811,10 +811,10 @@  (define-public gcc-13
               (snippet gcc-canadian-cross-objdump-snippet)))
     (arguments
      (substitute-keyword-arguments (package-arguments gcc-11)
-       ((#:phases phases #~%standard-phases)
+       ((#:phases phases '%standard-phases)
        (if (target-hurd?)
-           #~(modify-phases #$phases
-               (delete 'patch-hurd-libpthread))
+           `(modify-phases ,phases
+              (delete 'patch-hurd-libpthread))
            phases))))
     (properties
      `((compiler-cpu-architectures
@@ -841,8 +841,8 @@  (define-public gcc-14
               (modules '((guix build utils)))
               (snippet gcc-canadian-cross-objdump-snippet)))
     (arguments (substitute-keyword-arguments (package-arguments gcc-13)
-                 ((#:phases phases #~%standard-phases)
-                  #~(modify-phases #$phases
+                 ((#:phases phases '%standard-phases)
+                  `(modify-phases ,phases
                       (add-before 'configure 'pre-x86-configure
                         (lambda _
                           (substitute* "gcc/config/i386/t-linux64"