diff mbox series

[bug#73128,gnome-team,07/12] gnu: Add libei.

Message ID b4a74c9ed2d3a3e93efeac660debdf252b9bd61c.1725829379.git.liliana.prikler@gmail.com
State New
Headers show
Series Mini update dump | expand

Commit Message

Liliana Marie Prikler Sept. 8, 2024, 6:47 p.m. UTC
* gnu/packages/freedesktop.scm (libei): New variable.

Co-authored-by: Vivien Kraus <vivien@planete-kraus.eu>
---
 gnu/packages/freedesktop.scm | 40 ++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Maxim Cournoyer Sept. 11, 2024, 5:47 a.m. UTC | #1
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/freedesktop.scm (libei): New variable.
>
> Co-authored-by: Vivien Kraus <vivien@planete-kraus.eu>

[...]

> +(define-public libei
> +  (package
> +    (name "libei")
> +    (version "1.3.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://gitlab.freedesktop.org/libinput/libei.git")
> +                    (commit version)))
> +              (sha256
> +               (base32
> +                "0idbl20ax060s7m435rszfv7c0bvpinjvq45qbqwvcvp0hg8r9y8"))
> +              (snippet
> +               #~(begin
> +                   (use-modules (guix build utils))
> +                   (substitute* "test/meson.build"
> +                     (("subproject\\('munit'")
> +                      "# subproject('munit'")
> +                     ((", fallback: \\['munit', 'munit_dep'\\]")
> +                      ""))
> +                   (delete-file-recursively "subprojects")))))

What is the above snippet for?  A comment would be great.

> +    (build-system meson-build-system)
> +    (arguments
> +     (list
> +      #:configure-flags #~'("-Ddocumentation=api" ;protocol requires hugo
> +                            "-Dsd-bus-provider=libelogind")))
> +    (inputs
> +     (list elogind libevdev libxkbcommon))
> +    (propagated-inputs
> +     ;; liboeffis-1.0.pc requires.private libelogind
> +     (list elogind))
> +    (native-inputs
> +     (list doxygen libxml2 munit pkg-config python python-attrs python-black python-dbusmock python-jinja2 python-pytest python-structlog valgrind/interactive))

160 chars is a tad long for our 80 columns maximum width convention :-).

> +    (home-page "https://libinput.pages.freedesktop.org/libei/")
> +    (synopsis "Emulated Input protocol implementation")
> +    (description
> +     "Libei provides a client and server implementation of the @acronym{EI,Emulated

I think you can safely add a space after the comma, for extra
readability (and allowing M-q to break tE long line).

Otherwise, LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cb1d625d24..5ce90e1f69 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -735,6 +735,46 @@  (define-public libinput-minimal
                "-Ddebug-gui=false"    ;requires gtk+@3
                ,flags))))))
 
+(define-public libei
+  (package
+    (name "libei")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/libinput/libei.git")
+                    (commit version)))
+              (sha256
+               (base32
+                "0idbl20ax060s7m435rszfv7c0bvpinjvq45qbqwvcvp0hg8r9y8"))
+              (snippet
+               #~(begin
+                   (use-modules (guix build utils))
+                   (substitute* "test/meson.build"
+                     (("subproject\\('munit'")
+                      "# subproject('munit'")
+                     ((", fallback: \\['munit', 'munit_dep'\\]")
+                      ""))
+                   (delete-file-recursively "subprojects")))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:configure-flags #~'("-Ddocumentation=api" ;protocol requires hugo
+                            "-Dsd-bus-provider=libelogind")))
+    (inputs
+     (list elogind libevdev libxkbcommon))
+    (propagated-inputs
+     ;; liboeffis-1.0.pc requires.private libelogind
+     (list elogind))
+    (native-inputs
+     (list doxygen libxml2 munit pkg-config python python-attrs python-black python-dbusmock python-jinja2 python-pytest python-structlog valgrind/interactive))
+    (home-page "https://libinput.pages.freedesktop.org/libei/")
+    (synopsis "Emulated Input protocol implementation")
+    (description
+     "Libei provides a client and server implementation of the @acronym{EI,Emulated
+Input} protocol for Wayland compositors.")
+    (license license:x11)))
+
 (define-public libxdg-basedir
   (package
     (name "libxdg-basedir")