diff mbox series

[bug#73010] gnu: Add fmt-11.

Message ID b4701f6844ba743cd5c32df149bc786dcb60ca78.1725395445.git.code@greghogan.com
State New
Headers show
Series [bug#73010] gnu: Add fmt-11. | expand

Commit Message

Greg Hogan Sept. 3, 2024, 8:32 p.m. UTC
* gnu/packages/pretty-print.scm (fmt-11): New variable.
(fmt-10): Inherit from fmt-11.

Change-Id: Ic9f28cfb5a805f33beaad9794d69f992a5a27652
---
 gnu/packages/pretty-print.scm | 18 +++++++++++++++---
 1 file changed, 15 insertions(+), 3 deletions(-)


base-commit: 19e0b937857563e77841a4fc5433589fa98c810d

Comments

Z572 Sept. 9, 2024, 1:20 p.m. UTC | #1
Greg Hogan <code@greghogan.com> writes:

> * gnu/packages/pretty-print.scm (fmt-11): New variable.
> (fmt-10): Inherit from fmt-11.
>
> Change-Id: Ic9f28cfb5a805f33beaad9794d69f992a5a27652
> ---
>  gnu/packages/pretty-print.scm | 18 +++++++++++++++---
>  1 file changed, 15 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
> index d8ff1664b47..3b9bdbb1527 100644
> --- a/gnu/packages/pretty-print.scm
> +++ b/gnu/packages/pretty-print.scm
> @@ -170,17 +170,17 @@ (define-public enscript
>  different programming languages.")
>      (license gpl3+)))
>  
> -(define-public fmt-10
> +(define-public fmt-11
>    (package
>      (name "fmt")
> -    (version "10.2.1")
> +    (version "11.0.2")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
>                             version "/fmt-" version ".zip"))

Adjust it to git-fetch. Because this is better.

>         (sha256
> -        (base32 "1j8nln7rql2nxkhdlgpmx1c1dp6dyxnar1n5r7sjg0rws6i5289i"))))
> +        (base32 "0ralkidhqa16gyx8n1gm7r1d41rm2vf8zgd726g7b37kpjz5iz20"))))
>      (build-system cmake-build-system)
>      (arguments '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
>      (native-inputs (list unzip))
> @@ -192,6 +192,18 @@ (define-public fmt-10
>      ;; The library is bsd-2, but documentation and tests include other licenses.
>      (license (list bsd-2 bsd-3 psfl))))
>  
> +(define-public fmt-10
> +  (package
> +    (inherit fmt-11)
> +    (version "10.2.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
> +                           version "/fmt-" version ".zip"))
> +       (sha256
> +        (base32 "1j8nln7rql2nxkhdlgpmx1c1dp6dyxnar1n5r7sjg0rws6i5289i"))))))
> +
>  (define-public fmt-9
>    (package
>      (inherit fmt-10)
>
> base-commit: 19e0b937857563e77841a4fc5433589fa98c810d

push, close.
diff mbox series

Patch

diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index d8ff1664b47..3b9bdbb1527 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -170,17 +170,17 @@  (define-public enscript
 different programming languages.")
     (license gpl3+)))
 
-(define-public fmt-10
+(define-public fmt-11
   (package
     (name "fmt")
-    (version "10.2.1")
+    (version "11.0.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
                            version "/fmt-" version ".zip"))
        (sha256
-        (base32 "1j8nln7rql2nxkhdlgpmx1c1dp6dyxnar1n5r7sjg0rws6i5289i"))))
+        (base32 "0ralkidhqa16gyx8n1gm7r1d41rm2vf8zgd726g7b37kpjz5iz20"))))
     (build-system cmake-build-system)
     (arguments '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
     (native-inputs (list unzip))
@@ -192,6 +192,18 @@  (define-public fmt-10
     ;; The library is bsd-2, but documentation and tests include other licenses.
     (license (list bsd-2 bsd-3 psfl))))
 
+(define-public fmt-10
+  (package
+    (inherit fmt-11)
+    (version "10.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
+                           version "/fmt-" version ".zip"))
+       (sha256
+        (base32 "1j8nln7rql2nxkhdlgpmx1c1dp6dyxnar1n5r7sjg0rws6i5289i"))))))
+
 (define-public fmt-9
   (package
     (inherit fmt-10)