diff mbox series

[bug#60837,v2] gnu: Add emacs-auto-compile.

Message ID b43278001db0ec3802381ed284595a937094c90d.1673872692.git.csantosb@inventati.org
State New
Headers show
Series [bug#60837,v2] gnu: Add emacs-auto-compile. | expand

Commit Message

Cayetano Santos Jan. 16, 2023, 12:38 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-auto-compile): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 238f965c331990459a69cbc713ca951ad40e6044

Comments

Liliana Marie Prikler Jan. 16, 2023, 2:31 p.m. UTC | #1
Am Montag, dem 16.01.2023 um 13:38 +0100 schrieb Cayetano Santos:
> * gnu/packages/emacs-xyz.scm (emacs-auto-compile): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 5f60d82ad5..ea97cb09a2 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -259,6 +259,28 @@ (define-module (gnu packages emacs-xyz)
>  ;;; Emacs hacking.
>  ;;;
>  
> +(define-public emacs-auto-compile
> +  (package
> +    (name "emacs-auto-compile")
> +    (version "1.7.2")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url
> "https://github.com/emacscollective/auto-compile.git")
> +                    (commit version)))
> +              (sha256
> +               (base32
> +               
> "1njnyilv6lxnbvi6yrgzg6qjhf6vgh4fpag4hav1j45718y6kd31"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs (list emacs-compat emacs-packed))
> +    (home-page "https://github.com/emacscollective/auto-compile")
> +    (synopsis "Automatically compile Emacs Lisp libraries")
> +    (description
> +     "This package provides two minor modes which automatically
> recompile Emacs Lisp
Note how you're exceeding fill-column.
> +source files. Together these modes guarantee that Emacs never loads 
Use two spaces at the end of sentences.
> outdated
> +byte code files.")
> +    (license license:gpl3+)))
> +
I also moved this before emacs-auto-sudoedit.  Placing packages
directly at the start or end f files makes it mildly harder to rebase.

The package appears to build fine with both emacs and emacs-minimal, so
if there's no objection, I'll push this (with some fixes re the above
points) on the 29th.

Cheers
Deslauriers, Douglas via Guix-patches" via Jan. 16, 2023, 3:02 p.m. UTC | #2
>lun. 16 janv. 2023 at 15:31, Liliana Marie Prikler 
><liliana.prikler@gmail.com> ...

> Am Montag, dem 16.01.2023 um 13:38 +0100 schrieb Cayetano 
> Santos:
>> * gnu/packages/emacs-xyz.scm (emacs-auto-compile): New 
>> variable.
>> ---
>>  gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
>>  1 file changed, 22 insertions(+)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm 
>> b/gnu/packages/emacs-xyz.scm
>> index 5f60d82ad5..ea97cb09a2 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -259,6 +259,28 @@ (define-module (gnu packages emacs-xyz)
>>  ;;; Emacs hacking.
>>  ;;;
>>
>> +(define-public emacs-auto-compile
>> +  (package
>> +    (name "emacs-auto-compile")
>> +    (version "1.7.2")
>> +    (source (origin
>> +              (method git-fetch)
>> +              (uri (git-reference
>> +                    (url
>> "https://github.com/emacscollective/auto-compile.git")
>> +                    (commit version)))
>> +              (sha256
>> +               (base32
>> +
>> "1njnyilv6lxnbvi6yrgzg6qjhf6vgh4fpag4hav1j45718y6kd31"))))
>> +    (build-system emacs-build-system)
>> +    (propagated-inputs (list emacs-compat emacs-packed))
>> +    (home-page 
>> "https://github.com/emacscollective/auto-compile")
>> +    (synopsis "Automatically compile Emacs Lisp libraries")
>> +    (description
>> +     "This package provides two minor modes which 
>> automatically
>> recompile Emacs Lisp
> Note how you're exceeding fill-column.
>> +source files. Together these modes guarantee that Emacs never 
>> loads
> Use two spaces at the end of sentences.

Sorry for that, won’t forget next time.

>> outdated
>> +byte code files.")
>> +    (license license:gpl3+)))

> I also moved this before emacs-auto-sudoedit.  Placing packages
> directly at the start or end f files makes it mildly harder to 
> rebase.
>
> The package appears to build fine with both emacs and 
> emacs-minimal, so
> if there's no objection, I'll push this (with some fixes re the 
> above
> points) on the 29th.

Fine with me.

Cheers,
Maxim Cournoyer Jan. 16, 2023, 4:47 p.m. UTC | #3
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Montag, dem 16.01.2023 um 13:38 +0100 schrieb Cayetano Santos:
>> * gnu/packages/emacs-xyz.scm (emacs-auto-compile): New variable.
>> ---
>>  gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
>>  1 file changed, 22 insertions(+)
>> 
>> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
>> index 5f60d82ad5..ea97cb09a2 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -259,6 +259,28 @@ (define-module (gnu packages emacs-xyz)
>>  ;;; Emacs hacking.
>>  ;;;
>>  
>> +(define-public emacs-auto-compile
>> +  (package
>> +    (name "emacs-auto-compile")
>> +    (version "1.7.2")
>> +    (source (origin
>> +              (method git-fetch)
>> +              (uri (git-reference
>> +                    (url
>> "https://github.com/emacscollective/auto-compile.git")
>> +                    (commit version)))
>> +              (sha256
>> +               (base32
>> +               
>> "1njnyilv6lxnbvi6yrgzg6qjhf6vgh4fpag4hav1j45718y6kd31"))))
>> +    (build-system emacs-build-system)
>> +    (propagated-inputs (list emacs-compat emacs-packed))
>> +    (home-page "https://github.com/emacscollective/auto-compile")
>> +    (synopsis "Automatically compile Emacs Lisp libraries")
>> +    (description
>> +     "This package provides two minor modes which automatically
>> recompile Emacs Lisp
> Note how you're exceeding fill-column.
>> +source files. Together these modes guarantee that Emacs never loads 
> Use two spaces at the end of sentences.
>> outdated
>> +byte code files.")
>> +    (license license:gpl3+)))
>> +
> I also moved this before emacs-auto-sudoedit.  Placing packages
> directly at the start or end f files makes it mildly harder to rebase.
>
> The package appears to build fine with both emacs and emacs-minimal, so
> if there's no objection, I'll push this (with some fixes re the above
> points) on the 29th.

Make sure to use two spaces between sentences.  Other than that, LGTM
too, so feel free to push it already.
Liliana Marie Prikler Jan. 29, 2023, 7:35 a.m. UTC | #4
Am Montag, dem 16.01.2023 um 11:47 -0500 schrieb Maxim Cournoyer:
> Hi,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > Am Montag, dem 16.01.2023 um 13:38 +0100 schrieb Cayetano Santos:
> > > * gnu/packages/emacs-xyz.scm (emacs-auto-compile): New variable.
> > > ---
> > >  gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
> > >  1 file changed, 22 insertions(+)
> > > 
> > > diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-
> > > xyz.scm
> > > index 5f60d82ad5..ea97cb09a2 100644
> > > --- a/gnu/packages/emacs-xyz.scm
> > > +++ b/gnu/packages/emacs-xyz.scm
> > > @@ -259,6 +259,28 @@ (define-module (gnu packages emacs-xyz)
> > >  ;;; Emacs hacking.
> > >  ;;;
> > >  
> > > +(define-public emacs-auto-compile
> > > +  (package
> > > +    (name "emacs-auto-compile")
> > > +    (version "1.7.2")
> > > +    (source (origin
> > > +              (method git-fetch)
> > > +              (uri (git-reference
> > > +                    (url
> > > "https://github.com/emacscollective/auto-compile.git")
> > > +                    (commit version)))
> > > +              (sha256
> > > +               (base32
> > > +               
> > > "1njnyilv6lxnbvi6yrgzg6qjhf6vgh4fpag4hav1j45718y6kd31"))))
> > > +    (build-system emacs-build-system)
> > > +    (propagated-inputs (list emacs-compat emacs-packed))
> > > +    (home-page
> > > "https://github.com/emacscollective/auto-compile")
> > > +    (synopsis "Automatically compile Emacs Lisp libraries")
> > > +    (description
> > > +     "This package provides two minor modes which automatically
> > > recompile Emacs Lisp
> > Note how you're exceeding fill-column.
> > > +source files. Together these modes guarantee that Emacs never
> > > loads 
> > Use two spaces at the end of sentences.
> > > outdated
> > > +byte code files.")
> > > +    (license license:gpl3+)))
> > > +
> > I also moved this before emacs-auto-sudoedit.  Placing packages
> > directly at the start or end f files makes it mildly harder to
> > rebase.
> > 
> > The package appears to build fine with both emacs and emacs-
> > minimal, so if there's no objection, I'll push this (with some
> > fixes re the above points) on the 29th.
> 
> Make sure to use two spaces between sentences.  Other than that, LGTM
> too, so feel free to push it already.
Pushed with the spaces :)

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5f60d82ad5..ea97cb09a2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -259,6 +259,28 @@  (define-module (gnu packages emacs-xyz)
 ;;; Emacs hacking.
 ;;;
 
+(define-public emacs-auto-compile
+  (package
+    (name "emacs-auto-compile")
+    (version "1.7.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emacscollective/auto-compile.git")
+                    (commit version)))
+              (sha256
+               (base32
+                "1njnyilv6lxnbvi6yrgzg6qjhf6vgh4fpag4hav1j45718y6kd31"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-compat emacs-packed))
+    (home-page "https://github.com/emacscollective/auto-compile")
+    (synopsis "Automatically compile Emacs Lisp libraries")
+    (description
+     "This package provides two minor modes which automatically recompile Emacs Lisp
+source files. Together these modes guarantee that Emacs never loads outdated
+byte code files.")
+    (license license:gpl3+)))
+
 (define-public emacs-geiser
   (package
     (name "emacs-geiser")