diff mbox series

[bug#62156,v4,1/2] gnu: Add atftp.

Message ID b423186f49dfdfff336d4ff8058fe7190c132a73.1679372740.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#62156,v4,1/2] gnu: Add atftp. | expand

Commit Message

Felix Lechner March 21, 2023, 4:25 a.m. UTC
* gnu/packages/networking.scm (atftp): New variable.

Thanks to Josselin Poiret and Bruno Victal for their generous and detailed
reviews of this item!
---
 gnu/packages/networking.scm | 43 +++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)


base-commit: f9702aa9fdfded5c62da43197f8cea5eeba30803

Comments

Ludovic Courtès March 27, 2023, 4:49 p.m. UTC | #1
Hi,

Felix Lechner <felix.lechner@lease-up.com> skribis:

> * gnu/packages/networking.scm (atftp): New variable.
>
> Thanks to Josselin Poiret and Bruno Victal for their generous and detailed
> reviews of this item!

I tweaked the description (to start with a full sentence) and passed it
through ‘guix style’.

> For the atftp package added in the preceeding commit, lint produced this
> warning:
>
>   gnu/packages/networking.scm:2924:5: atftp@0.8.0:
>     URI https://git.code.sf.net/p/atftp/code not reachable:
>       404 ("Not Found")
>
> Thanks to Sergey Trofimov for suggesting a fix! [1]
>
>   [1]  https://issues.guix.gnu.org/62156#3
>
> It was implemented here, and the warning disappeared.
>
> * guix/lint.scm (check-source): Append "/info/refs" to git-reference-url.
>
> Co-authored-by: Sergey Trofimov <sarg@sarg.org.ru>

Nice.  I adjusted ‘tests/lint.scm’ accordingly.

Applied both; thank you, and thanks to the reviewers!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3fac05c411..7f843214fb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2916,6 +2916,49 @@  (define-public speedtest-cli
 speedtest.net.")
     (license license:asl2.0)))
 
+(define-public atftp
+  (package
+    (name "atftp")
+    (version "0.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.code.sf.net/p/atftp/code")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "019qrh2wpvr577ksvs3s82q6kiqm5i6869aj7qba326b59lhkxrc"))
+       (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'autoreconf
+            (lambda _
+              (invoke "autoreconf" "-vif"))))))
+    (native-inputs
+     (list autoconf
+           automake
+           perl
+           pkg-config))
+    (inputs
+     (list pcre2
+           procps
+           readline
+           tcp-wrappers))
+    (home-page "https://sourceforge.net/projects/atftp/")
+    (synopsis "Advanced TFTP server and client")
+    (description
+     "Multi-threaded TFTP server that implements all options, including all
+extensions, as specified in RFC 1350, RFC 2090, RFC 2347, RFC 2348, RFC 2349
+and RFC7440.  Atftpd also supports a multicast protocol known as mtftp, which
+was defined in the PXE specification.
+
+The server is socket activated by default but supports being started from
+inetd(8) as well as in daemon mode.")
+    (license license:gpl2+)))
+
 (define-public tftp-hpa
   (package
     (name "tftp-hpa")