diff mbox series

[bug#72835,qt-team,30/38] gnu: python-shiboken-6: Update to 6.7.2.

Message ID b3fb1ab9a5d504cfa7cc7299fc0535fc34d76ad6.1724775512.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series update qt6 to 6.7.2 | expand

Commit Message

Z572 Aug. 27, 2024, 4:25 p.m. UTC
* gnu/packages/qt.scm (python-shiboken-6): Update to 6.7.2.

Change-Id: I899a3a966ab35108fe5a6029a4b7f3079c48ae8f
---
 gnu/packages/qt.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Maxim Cournoyer Sept. 13, 2024, 3:23 p.m. UTC | #1
Hi,

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/qt.scm (python-shiboken-6): Update to 6.7.2.
>
> Change-Id: I899a3a966ab35108fe5a6029a4b7f3079c48ae8f
> ---
>  gnu/packages/qt.scm | 7 +++----
>  1 file changed, 3 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 0102c0f27c..7067e46040 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -4818,7 +4818,7 @@ (define-public python-shiboken-6
>    (package
>      (inherit python-shiboken-2)
>      (name "python-shiboken-6")
> -    (version "6.6.2")
> +    (version "6.7.2")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "mirror://qt/QtForPython/pyside6/PySide6-"
> @@ -4826,7 +4826,7 @@ (define-public python-shiboken-6
>                                    version ".tar.xz"))
>                (sha256
>                 (base32
> -                "1w690jpxrski7c71gx05q5fvl2117lnjj5ih8iwckx3s9mlhnqhl"))))
> +                "1iv8wfc5sfx5xr4b3bhbaqagx8qidx5wl1kzvifsmjbqdq6hsars"))))
>      (build-system cmake-build-system)
>      (inputs
>       (modify-inputs (package-inputs python-shiboken-2)
> @@ -4846,8 +4846,7 @@ (define-public python-shiboken-6
>             "-DCMAKE_SKIP_RPATH=TRUE"
>             (string-append "-DCMAKE_MODULE_LINKER_FLAGS=-Wl,-rpath="
>                            #$output "/lib")
> -           #$flags))))
> -    (properties `((upstream-name . "pyside-setup")))))
> +           #$flags))))))

Is the above property removal intended?  It's not listed in the
changelog commit message.  I doubt CVE databases have dropped the old
name, but I haven't checked.
Z572 Sept. 18, 2024, 2:05 a.m. UTC | #2
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hi,
>
> Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
>
>> * gnu/packages/qt.scm (python-shiboken-6): Update to 6.7.2.
>>
>> Change-Id: I899a3a966ab35108fe5a6029a4b7f3079c48ae8f
>> ---
>>  gnu/packages/qt.scm | 7 +++----
>>  1 file changed, 3 insertions(+), 4 deletions(-)
>>
>> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
>> index 0102c0f27c..7067e46040 100644
>> --- a/gnu/packages/qt.scm
>> +++ b/gnu/packages/qt.scm
>> @@ -4818,7 +4818,7 @@ (define-public python-shiboken-6
>>    (package
>>      (inherit python-shiboken-2)
>>      (name "python-shiboken-6")
>> -    (version "6.6.2")
>> +    (version "6.7.2")
>>      (source (origin
>>                (method url-fetch)
>>                (uri (string-append "mirror://qt/QtForPython/pyside6/PySide6-"
>> @@ -4826,7 +4826,7 @@ (define-public python-shiboken-6
>>                                    version ".tar.xz"))
>>                (sha256
>>                 (base32
>> -                "1w690jpxrski7c71gx05q5fvl2117lnjj5ih8iwckx3s9mlhnqhl"))))
>> +                "1iv8wfc5sfx5xr4b3bhbaqagx8qidx5wl1kzvifsmjbqdq6hsars"))))
>>      (build-system cmake-build-system)
>>      (inputs
>>       (modify-inputs (package-inputs python-shiboken-2)
>> @@ -4846,8 +4846,7 @@ (define-public python-shiboken-6
>>             "-DCMAKE_SKIP_RPATH=TRUE"
>>             (string-append "-DCMAKE_MODULE_LINKER_FLAGS=-Wl,-rpath="
>>                            #$output "/lib")
>> -           #$flags))))
>> -    (properties `((upstream-name . "pyside-setup")))))
>> +           #$flags))))))
>
> Is the above property removal intended?  It's not listed in the
> changelog commit message.  I doubt CVE databases have dropped the old
> name, but I haven't checked.

It seems that guix refresh cannot update to 6.7 if it is currently 6.6,
but it can update to 6.7 if it is 6.5. I added this part back.
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0102c0f27c..7067e46040 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4818,7 +4818,7 @@  (define-public python-shiboken-6
   (package
     (inherit python-shiboken-2)
     (name "python-shiboken-6")
-    (version "6.6.2")
+    (version "6.7.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://qt/QtForPython/pyside6/PySide6-"
@@ -4826,7 +4826,7 @@  (define-public python-shiboken-6
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1w690jpxrski7c71gx05q5fvl2117lnjj5ih8iwckx3s9mlhnqhl"))))
+                "1iv8wfc5sfx5xr4b3bhbaqagx8qidx5wl1kzvifsmjbqdq6hsars"))))
     (build-system cmake-build-system)
     (inputs
      (modify-inputs (package-inputs python-shiboken-2)
@@ -4846,8 +4846,7 @@  (define-public python-shiboken-6
            "-DCMAKE_SKIP_RPATH=TRUE"
            (string-append "-DCMAKE_MODULE_LINKER_FLAGS=-Wl,-rpath="
                           #$output "/lib")
-           #$flags))))
-    (properties `((upstream-name . "pyside-setup")))))
+           #$flags))))))
 
 (define-public python-pyside-2
   (package