[bug#77371,10/12] gnu: Add python-decaylanguage.

Message ID b3ddf7d9e6ccf0f304c319aa6548e3a34440fc19.1743288280.git.monego@posteo.net
State New
Headers
Series Add packages from the scikit-hep project |

Commit Message

Vinicius Monego March 29, 2025, 11:01 p.m. UTC
  * gnu/packages/python-science.scm (python-decaylanguage): New variable.

Change-Id: I5c709016f80b19cef22105bff42ca62b8f384f1b
---
 gnu/packages/python-science.scm | 36 +++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index b17c543619..c2f23c8d55 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -61,6 +61,7 @@  (define-module (gnu packages python-science)
   #:use-module (gnu packages digest)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages geo)
+  #:use-module (gnu packages graphviz)
   #:use-module (gnu packages image)
   #:use-module (gnu packages image-processing)
   #:use-module (gnu packages machine-learning)
@@ -1171,6 +1172,41 @@  (define-public python-particle
 particle information and extra goodies.")
     (license license:bsd-3)))
 
+(define-public python-decaylanguage
+  (package
+    (name "python-decaylanguage")
+    (version "0.18.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "decaylanguage" version))
+       (sha256
+        (base32 "0kc9i9k51kg2zv8dwywpigiipxzmyxpzb101imjsvv1licip7b8v"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; This file fails to be collected with "DeprecationWarning: setDaemon()
+      ;; is deprecated, set the daemon attribute instead".
+      #:test-flags #~(list "--ignore" "tests/test_convert.py")))
+    (propagated-inputs (list python-attrs
+                             python-graphviz
+                             python-hepunits
+                             python-lark-parser
+                             python-numpy
+                             python-pandas
+                             python-particle
+                             python-plumbum))
+    (native-inputs (list python-hatch-vcs
+                         python-hatchling
+                         python-pytest))
+    (home-page "https://decaylanguage.readthedocs.io/en/latest/")
+    (synopsis "Language to describe, manipulate and convert particle decays")
+    (description "DecayLanguage implements a language to describe and convert
+particle decays between digital representations, effectively making it
+possible to interoperate several fitting programs.  Particular interest is
+given to programs dedicated to amplitude analyses.")
+    (license license:bsd-3)))
+
 (define-public python-trimesh
   (package
     (name "python-trimesh")