diff mbox series

[bug#40485] gnu: Update libxfce4ui to 4.15.2.

Message ID b3aac476-62de-b714-76fd-7268d6d98ac8@riseup.net
State Accepted
Headers show
Series [bug#40485] gnu: Update libxfce4ui to 4.15.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Naga Malleswari April 7, 2020, 12:55 p.m. UTC
Submission of patch for updating description for libxfce4ui

Comments

Naga Malleswari April 7, 2020, 1:40 p.m. UTC | #1
Hi Danny


 (inputs `(("libsm" ,libsm)
              ("libice" ,libice)
              ;; FIXME: required by libxfce4ui-1.pc, so should be
propagated,
              ;; but will lead to a conflict with gtk+.
              ("gtk+-2" ,gtk+-2)

I understand that xfce4-embed-plugin failed after libxfce4ui is updated
because of the conflict with the inputs. What is suggested to do.  

On 07/04/20 6:26 pm, GNU bug Tracking System wrote:
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 40485@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
Danny Milosavljevic April 7, 2020, 1:57 p.m. UTC | #2
Build via

  ./pre-inst-env guix build -K libxfce4ui

Check /tmp/guix-build-xfce4-embed-plugin-1.6.0.drv-*/*/config.log for libxfce4ui
and see what the surrounding lines say.

If that doesn't help,

  ./pre-inst-env guix environment --pure libxfce4ui

then

  pkg-config --cflags --libs libxfce4ui-1
Danny Milosavljevic April 7, 2020, 2:01 p.m. UTC | #3
I meant:

Build via

  ./pre-inst-env guix build -K xfce4-embed-plugin

Check /tmp/guix-build-xfce4-embed-plugin-1.6.0.drv-*/*/config.log for libxfce4ui
and see what the surrounding lines say.

If that doesn't help,

  ./pre-inst-env guix environment --pure xfce4-embed-plugin

then

   pkg-config --cflags --libs libxfce4ui-1
Danny Milosavljevic April 7, 2020, 2:07 p.m. UTC | #4
Then check the directories $PKG_CONFIG_PATH for libxfce4ui* .

In this case there's a libxfce4ui-2, which means they have changed the API
version because there was an incompatible change (previously it was
libxfce4ui-1).

So update xfce4-embed-plugin as well and hope they have adapted to the API
change (if not, we'll just get an error message again).

This will probably happen for quite a few packages, so it's gonna take some
work.
Naga Malleswari April 7, 2020, 2:17 p.m. UTC | #5
I thought of the same but

xfce4-embed-plugin version is latest in guix. (1.6.0)


I got this error:

*** The required package libxfce4ui-1 was not found on your system.
*** Please install libxfce4ui-1 (atleast version 4.8.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you

On 07/04/20 7:37 pm, Danny Milosavljevic wrote:
> Then check the directories $PKG_CONFIG_PATH for libxfce4ui* .
>
> In this case there's a libxfce4ui-2, which means they have changed the API
> version because there was an incompatible change (previously it was
> libxfce4ui-1).
>
> So update xfce4-embed-plugin as well and hope they have adapted to the API
> change (if not, we'll just get an error message again).
>
> This will probably happen for quite a few packages, so it's gonna take some
> work.
Danny Milosavljevic April 7, 2020, 2:23 p.m. UTC | #6
Upstream (the actual author) is https://docs.xfce.org/panel-plugins/xfce4-embed-plugin 
according to our page https://guix.gnu.org/packages/xfce4-embed-plugin-1.6.0/ .

Their latest release was in 2015, so I don't think they adapted to the new libxfce4ui.

That's too bad.

There are multiple possible ways to proceed:

(1) Delete xfce4-embed-plugin, if possible (if nobody is using it and if it has
security problems anyway etc), or
(2) Keep both packages of libxfce4ui.  Use the old package for
xfce4-embed-plugin and the new package for the other dependents.

Please make sure to use ./pre-inst-env guix lint xfce4-embed-plugin libxfce4ui
(with the old unchanged version) to find out whether there are known security
problems with it.

If not, I'd prefer (2).
Naga Malleswari April 7, 2020, 7:17 p.m. UTC | #7
Hi

On 07/04/20 7:53 pm, Danny Milosavljevic wrote:
> (2) Keep both packages of libxfce4ui.  Use the old package for
> xfce4-embed-plugin and the new package for the other dependents.


(define-public libxfce4ui/latest
  (package
    (inherit libxfce4ui)
    (version "4.15.2")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://archive.xfce.org/src/xfce/"
                                  name "/" (version-major+minor version) "/"
                                  name "-" version ".tar.bz2"))
              (sha256
               (base32
                "0069da27chxrgylbzcm9vhzpfnvkii2n2dz8g6jlwfcr82arkayb"))))))


I Added this and tried. always its showing 4.15.2 not found. Unable to
trace the error.

> If not, I'd prefer (2).
Danny Milosavljevic April 7, 2020, 7:24 p.m. UTC | #8
Hi Naga,

On Wed, 8 Apr 2020 00:47:16 +0530
Naga Malleswari <nagamalli@riseup.net> wrote:

> On 07/04/20 7:53 pm, Danny Milosavljevic wrote:
> > (2) Keep both packages of libxfce4ui.  Use the old package for
> > xfce4-embed-plugin and the new package for the other dependents.  
> 
> 
> (define-public libxfce4ui/latest
>   (package
>     (inherit libxfce4ui)
>     (version "4.15.2")
>     (source (origin
>               (method url-fetch)
>               (uri (string-append "https://archive.xfce.org/src/xfce/"
>                                   name "/" (version-major+minor version) "/"
>                                   name "-" version ".tar.bz2"))
>               (sha256
>                (base32
>                 "0069da27chxrgylbzcm9vhzpfnvkii2n2dz8g6jlwfcr82arkayb"))))))
> 
> 
> I Added this and tried. always its showing 4.15.2 not found. Unable to
> trace the error.

That approach is good is principle.

But I'd do it the other way around--otherwise you have to update all libxfce4ui
references in all the other packages (which presumably can use the newer
version just fine).

So better rename the old libxfce4ui variable to libxfce4ui-1 and then
update the reference in xfce4-embed-plugin to use libxfce4ui-1, and
then introduce a new libxfce4ui variable with a similar body as your
libxfce4ui/latest had.

That means that everyone still referring to the libxfce4ui variable will get
the new version automatically.
Danny Milosavljevic April 7, 2020, 7:48 p.m. UTC | #9
Hi Naga,

On Wed, 8 Apr 2020 00:47:16 +0530
Naga Malleswari <nagamalli@riseup.net> wrote:

> (define-public libxfce4ui/latest
[...]
> 
> I Added this and tried. always its showing 4.15.2 not found. Unable to
> trace the error.

When processing which package?
Naga Malleswari April 8, 2020, 7:43 p.m. UTC | #10
I am getting weird outputs.

I tried building two versions of help2man/latest and libuv/latest which
were build the same way and they worked perfectly fine.


I tried these

https://paste.debian.net/1139190/


CASE1:

 ./pre-inst-env guix build libxfce4ui   is building 4.14.1

./pre-inst-env guix build libxfce4ui-1           error: libxfce4ui-1: unknown package

./pre-inst-env guix build libxfce4ui@4.15.2      error: libxfce4ui-4.15.2: unknown package


CasE 2: 
 ./pre-inst-env guix build libxfce4ui   is building 4.14.1

./pre-inst-env guix build libxfce4ui@4.15.2  resulted  error: libxfce4ui-4.15.2: unknown package


Am i missing something here........... orocess which worked fine for
help2man and libuv is not working for this.



On 08/04/20 1:18 am, Danny Milosavljevic wrote:
> Hi Naga,
>
> On Wed, 8 Apr 2020 00:47:16 +0530
> Naga Malleswari <nagamalli@riseup.net> wrote:
>
>> (define-public libxfce4ui/latest
> [...]
>> I Added this and tried. always its showing 4.15.2 not found. Unable to
>> trace the error.
> When processing which package?

THis one

 ./pre-inst-env guix build xfce4ui
diff mbox series

Patch

From 95e1a33913a13e49fe64a54222bf950dea8c54f3 Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Tue, 7 Apr 2020 18:22:41 +0530
Subject: [PATCH] gnu: Update libxfce4ui to 4.15.2.

* gnu/packages/xfce.scm (libxfce4ui): Update to 4.15.2.
---
 gnu/packages/xfce.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 0628b03207..d0f7da61b3 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -166,7 +166,7 @@  storage system.")
 (define-public libxfce4ui
   (package
     (name "libxfce4ui")
-    (version "4.14.1")
+    (version "4.15.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -174,7 +174,7 @@  storage system.")
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "1npjhznmnckhnylsv3l7p1zvhckhmp9d7vifs8w12kdfmrg0fjf4"))))
+                "0069da27chxrgylbzcm9vhzpfnvkii2n2dz8g6jlwfcr82arkayb"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
-- 
2.25.1