diff mbox series

[bug#49093] Add video-contact-sheet

Message ID b3a6a796f208c999bb3e2e426718919f1c9e1e56.camel@courrier.dev
State Accepted
Headers show
Series [bug#49093] Add video-contact-sheet | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pradana Adrinusa AUMARS June 18, 2021, 2:15 p.m. UTC
Add package definition for video-contact-sheet
diff mbox series

Patch

From 9851db2b3036ee3d5e8ef85ed8bae2f6398702e0 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Fri, 18 Jun 2021 16:13:07 +0200
Subject: [PATCH] gnu: Add video-contact-sheet

---
 gnu/packages/video.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e3f4f59b4c..ba3035cf45 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -51,6 +51,7 @@ 
 ;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
 ;;; Copyright © 2021 David Wilson <david@daviwil.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -96,6 +97,7 @@ 
   #:use-module (gnu packages avahi)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages cdrom)
@@ -5180,3 +5182,32 @@  information) NALUs (Network Abstraction Layer Unit) for inclusion into an h.264
 elementary stream are provided.")
     (home-page "https://github.com/szatmary/libcaption")
     (license license:expat)))
+
+(define-public video-contact-sheet
+  (package
+   (name "video-contact-sheet")
+   (version "1.13.4")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "http://p.outlyer.net/vcs/files/vcs-" version
+				".tar.gz"))
+            (sha256
+             (base32
+              "0jsl93r0rnybjcipqbww5hwsr9ln6kz1qnf32qfxdvhfw52n27fw"))))
+   (build-system gnu-build-system)
+   (arguments
+    `(#:phases (modify-phases %standard-phases
+                              (delete 'configure)
+                              (delete 'build)
+                              (delete 'check))
+      #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))))
+   (inputs
+    `(("bash" ,bash)
+      ("ffmpeg" ,ffmpeg)
+      ("imagemagick" ,imagemagick)))
+   (synopsis "Bash script to create contact sheets (preview images) from videos")
+   (description "This is a bash script meant to create video contact sheets (previews) of videos. Any video supported by mplayer and ffmpeg can be used. A note of warning: Unlike most similar tools it, by default, makes screenshots the same size as the video, see below for details on how to change this.
+
+Take a look at the documentation and/or use the –help and –fullhelp options to learn how to use it.")
+   (home-page "http://p.outlyer.net/vcs/")
+   (license license:lgpl3)))
-- 
2.32.0