diff mbox series

[bug#59999] gnu: Add nwg-launchers

Message ID b3796f8b6eb6b332fdbf21407972c78c978f782a.1670841891.git.florhizome@posteo.net
State New
Headers show
Series [bug#59999] gnu: Add nwg-launchers | expand

Commit Message

florhizome Dec. 12, 2022, 10:47 a.m. UTC
From: florhizome <florhizome@posteo.net>

* gnu/packages/wm.scm (nwg-launchers): New variable.
---
 gnu/packages/wm.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

florhizome March 14, 2023, 3:40 p.m. UTC | #1
Hey, 
consider this a ping.  
I think it would be good to have a module for general desktop utilities
, maybe desktop.scm. Maybe I will propose to open it with a new patch
for another outstanding package.
Cheers.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d3a7716c23..7f81efff96 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1806,6 +1806,31 @@  (define-public wlr-randr
     (description "wlr-randr is a utility to manage outputs of a Wayland compositor.")
     (license license:expat))) ; MIT license
 
+
+(define-public nwg-launchers
+  (package
+    (name "nwg-launchers")
+    (version "0.7.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/nwg-piotr/nwg-launchers")
+         (commit (string-append "v" version))))
+       (sha256
+        (base32 "0hq2qiqxvrw3g515ywcb676ljc8mdw3pyslgxr3vahizfljah1pv"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list git-minimal pkg-config))
+    (inputs
+     (list gtk-layer-shell gtkmm-3 json-modern-cxx librsvg))
+    (synopsis "GTK-based launchers")
+    (description "This package provides application grid, button bar and dmenu
+ applications for sway and other window managers.")
+    (home-page "https://github.com/nwg-piotr/nwg-launchers")
+    (license license:expat)))
+
 (define-public mako
   (package
     (name "mako")