[bug#77739] gnu: Add sbcl-stumpwm-stump-nm.
Commit Message
* gnu/packages/wm.scm (sbcl-stumpwm-stump-nm): New variable.
Change-Id: I155ab3fc653e118f3b3969374cfeb22f2c695819
---
gnu/packages/wm.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
base-commit: 2934de1447f87b361608ef3a2a756b8a5d2f42e6
prerequisite-patch-id: e1f9a928f816883d9eaaaabf4accbb56800f513e
Comments
Patch applied as 35c1f382944e727913020c03127be888bcb2352f.
Thanks.
@@ -2871,6 +2871,29 @@ (define-public sbcl-stumpwm-binwarp
mouse control mode for StumpWM.")
(license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+(define-public sbcl-stumpwm-stump-nm
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-stump-nm")
+ (arguments
+ '(#:asd-systems '("stump-nm")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "util/stump-nm"))))))
+ (home-page "https://github.com/stumpwm/stumpwm-contrib")
+ (inputs (list stumpwm
+ sbcl-babel
+ sbcl-alexandria
+ sbcl-dbus))
+ (synopsis "StumpWM NetworkManager integration")
+ (description "This module allows you to manage your Wi-Fi networks and VPN
+connections from within StumpWM itself. It is intentionally pretty bare-bones in
+features, in that it allows you to enable/disable connections, and no more. It is
+not a replacement for nmtui and/or nmcli.")
+ (license license:gpl3+)))
+
(define-public sbcl-stumpwm-ttf-fonts
(package
(inherit stumpwm-contrib)