diff mbox series

[bug#73190,1/3] gnu: make-libiberty: Install the header demangle.h.

Message ID b3584dbd4d5deb9cce9d382e0381950426b184ca.1726106463.git.mcsinyx@disroot.org
State New
Headers show
Series gnu: dyninst: Update to 13.0.0. | expand

Commit Message

guix-patches--- via Sept. 12, 2024, 2:28 a.m. UTC
This header is wanted by Dyninst.

* gnu/packages/gcc.scm (make-libiberty):
  Add include/demangle.h to install phase.

Change-Id: I01235071b75b412f55785d240cda248315b7a93e
---
 gnu/packages/gcc.scm | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 2f90024295b2..fef05b0c32d6 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1074,6 +1075,7 @@  (define (make-libiberty gcc)
                     (lib     (string-append out "/lib/"))
                     (include (string-append out "/include/")))
                (install-file "libiberty.a" lib)
+               (install-file "../include/demangle.h" include)
                (install-file "../include/libiberty.h" include)))))))
     (inputs '())
     (outputs '("out"))