diff mbox series

[bug#66802,21/21] gnu: Add rust-find-crate-0.6.

Message ID b336e953d29c6b9efe80c5da7d5cac8488bdd23a.1698532141.git.jaeme@runbox.com
State New
Headers show
Series Add More Rust Crates. | expand

Commit Message

Jaeme Sifat Oct. 28, 2023, 10:53 p.m. UTC
* gnu/packages/crates-io.scm (rust-find-crate-0.6): New variable.

Signed-off-by: Jaeme Sifat <jaeme@runbox.com>
Change-Id: Iec69b833eb9f4cd0fd195d9b636cd173fb502f57
---
 gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c77bebbcc8..ac91d8554d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -25903,6 +25903,30 @@  (define-public rust-field-offset-0.3
 implementation.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-find-crate-0.6
+  (package
+    (name "rust-find-crate")
+    (version "0.6.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "find-crate" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1ljpkh11gj7940xwz47xjhsvfbl93c2q0ql7l2v0w77amjx8paar"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-toml" ,rust-toml-0.5))
+       #:cargo-development-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+                                   ("rust-quote" ,rust-quote-1)
+                                   ("rust-semver" ,rust-semver-0.11))))
+    (home-page "https://github.com/taiki-e/find-crate")
+    (synopsis "Find the crate name from the current Cargo.toml")
+    (description
+     "This package provides a way to find the crate name from the current
+Cargo.toml.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-findshlibs-0.10
   (package
     (name "rust-findshlibs")