diff mbox series

[bug#61968,gnome-team,v4,3/8] gnu: Add libdex.

Message ID b30e177cfe13eff4f8949967788a4e49a5555a63.1700166830.git.vivien@planete-kraus.eu
State New
Headers show
Series Update GNOME Builder to 44.2. | expand

Commit Message

Vivien Kraus Nov. 16, 2023, 4:45 p.m. UTC
* gnu/packages/glib.scm (libdex): New variable.

Change-Id: I834e45aff5e933e3e30276bb11030f84718ce72f
---
 gnu/packages/glib.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 2e3c5f0e8b..6e7996e686 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1515,3 +1515,38 @@  (define-public dbus-test-runner
     (description "A small little utility to run a couple of executables under a
 new DBus session for testing.")
     (license license:gpl3)))
+
+(define-public libdex
+  (package
+    (name "libdex")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnome/sources/" name "/"
+                           (version-major+minor version) "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32 "0fj4bggygdxgfsdrhc3zg1y2065g0skpz1l2bqwl0jqn9m3zbdc1"))))
+    (build-system meson-build-system)
+    (arguments
+     (list #:configure-flags #~'("-D" "docs=true")))
+    (native-inputs
+     (list gobject-introspection
+           gi-docgen
+           pkg-config
+           vala))
+    (inputs
+     (list glib
+           libsoup))
+    (home-page "https://gitlab.gnome.org/GNOME/libdex")
+    (synopsis "Library for future-based programming with glib")
+    (description
+     "Dex provides Future-based programming for GLib-based applications.
+
+It both integrates with and brings new features for application and library
+authors who want to manage concurrent code.
+
+Dex also provides Fibers which allow writing synchronous looking code in C
+that uses asynchronous and future-based APIs.")
+    (license license:lgpl2.1+)))