diff mbox series

[bug#42380,v4,4/9] gnu: Add go-github-com-dchest-uniuri.

Message ID b2cc6770b58badbe54a7f476bf87b9ba2058bc42.1622687706.git.nandre@riseup.net
State New
Headers show
Series [bug#42380,v4,1/9] gnu: Add go-torproject-org-ptlib. | expand

Commit Message

André Batista June 3, 2021, 3:17 a.m. UTC
* gnu/packages/golang.scm (go-github-com-dchest-uniuri): New variable.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 037163766d..08b5b6ba9b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7123,3 +7123,28 @@  Pseudo Random Function which is suitable for usage in message authentication
 codes and was based on the design created by Jean-Philippe Aumasson and Daniel
 J. Bernstein. ")
      (license license:cc0))))
+
+(define-public go-github-com-dchest-uniuri
+  (let ((commit "8902c56451e9b58ff940bbe5fec35d5f9c04584a")
+        (revision "0"))
+    (package
+     (name "go-github-com-dchest-uniuri")
+     (version (git-version "0.0.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dchest/uniuri")
+             (commit commit)))
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32
+         "1x5bsbm1nlphsv96zd0rbclfaa1swpz5bp14x7s5dbxp0awk2gd4"))))
+     (build-system go-build-system)
+     (arguments
+      '(#:import-path "github.com/dchest/uniuri"))
+     (home-page "https://github.com/dchest/uniuri")
+     (synopsis "Go library for random URIs")
+     (description "Package uniuri generates random strings good for use in
+Universal Resource Identifiers to uniquely identify objects.")
+     (license license:cc0))))