diff mbox series

[bug#38689] gnu: Add vl1-emulator

Message ID b2c94e56fecd791ec3fb287fe79d5c8c7cf6b582.camel@zrythm.org
State Accepted
Headers show
Series [bug#38689] gnu: Add vl1-emulator | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou March 21, 2020, 7:24 p.m. UTC
Hi,

Removed some unnecessary dependencies.

Thanks,
Alex

Comments

Marius Bakke March 29, 2020, 8:27 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Hi,
>
> Removed some unnecessary dependencies.

Thanks!  For some reason none of the patches would apply cleanly, and
git said the second patch was 'corrupt', but I merged them manually and
also fixed indentation and trailing whitespaces.

Sorry for the long feedback cycle, and thanks for bumping the issue.  :-)
diff mbox series

Patch

From 77bf5b5a618d4e835de81fb2af58c28c60bf4605 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 14:46:08 +0000
Subject: [PATCH 1/3] gnu: Add vl1-emulator.

* gnu/packages/music.scm (vl1-emulator): New variable.
---
 gnu/packages/music.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 16e69840df..954e82dc35 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5189,3 +5189,45 @@  featureful and easy to use.  It offers unlimited automation options, LV2
 plugin support, JACK support and chord assistance.")
    (home-page "https://www.zrythm.org")
    (license license:agpl3+)))
+
+(define-public vl1-emulator
+  (package
+    (name "vl1-emulator")
+    (version "1.1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/linuxmao-org/VL1-emulator.git")
+               (commit (string-append "v" version))
+               ;; bundles a specific commit of the DISTRHO plugin framework
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+           "1npc86vqma8gk1hawa0lii0r2xmnv846plyl1ci3bdswyrdk5chm"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no check target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)))) ; no configure target
+    (inputs
+     `(("cairo" ,cairo)
+       ("jack" ,jack-1)
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/linuxmao-org/VL1-emulator")
+    (synopsis "Emulator of Casio VL-Tone VL1")
+    (description "The VL1-Emulator is an emulator of Casio VL-Tone VL1, 
+based on source code by PolyValens, offered as an LV2 plugin and a 
+standalone JACK application.")
+    ;; Expat or CC0
+    (license (list license:expat license:cc0))))
-- 
2.25.1