diff mbox series

[bug#63903,v2,08/11] gnu: Add go-github-com-go-telegram-bot-api-telegram-bot-api.

Message ID b2c84659b4a1c871a8d521e497c34d16678da587.1685973062.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add miniflux. | expand

Commit Message

Hilton Chain June 5, 2023, 1:52 p.m. UTC
* gnu/packages/golang.scm (go-github-com-go-telegram-bot-api-telegram-bot-api): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4708d4395f..d8c20d2725 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10757,6 +10757,31 @@  (define-public go-github-com-tekwizely-go-parsing
 parsers, and related tools.")
       (license license:expat))))
 
+(define-public go-github-com-go-telegram-bot-api-telegram-bot-api
+  (package
+    (name "go-github-com-go-telegram-bot-api-telegram-bot-api")
+    (version "4.6.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/go-telegram-bot-api/telegram-bot-api")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1x6j0k3aiicsr8l53na99ci10zm3qpn2syz4f60fzh164w5k1l7w"))))
+    (build-system go-build-system)
+    (home-page "https://go-telegram-bot-api.dev/")
+    (arguments
+     (list #:tests? #f                  ; Upstream tests are broken.
+           #:import-path "github.com/go-telegram-bot-api/telegram-bot-api"))
+    (propagated-inputs
+     (list go-github-com-technoweenie-multipartstreamer))
+    (synopsis "Golang bindings for the Telegram Bot API")
+    (description
+     "This package provides Golang bindings for the Telegram Bot API.")
+    (license license:expat)))
+
 (define-public go-github.com-ulikunitz-xz
   (package
     (name "go-github.com-ulikunitz-xz")