diff mbox series

[bug#73040] gnu: Add micron.

Message ID b2ac45983fd6d8597f6550c6f51a031dad869452.1725543223.git.atai@atai.org
State New
Headers show
Series [bug#73040] gnu: Add micron. | expand

Commit Message

Andy Tai Sept. 5, 2024, 1:34 p.m. UTC
* gnu/packages/cron.scm (micron): New variable.

Change-Id: I1bd78df12b5ea7f17104a005659e9034c20403f1
---
 gnu/packages/cron.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
 create mode 100644 gnu/packages/cron.scm


base-commit: 993d6d2e7be4dac738629c76a51058f4dc5bc449
diff mbox series

Patch

diff --git a/gnu/packages/cron.scm b/gnu/packages/cron.scm
new file mode 100644
index 0000000000..1991ad4b60
--- /dev/null
+++ b/gnu/packages/cron.scm
@@ -0,0 +1,45 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Andy Tai <atai@atai.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cron)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages))
+
+
+(define-public micron
+  (package
+    (name "micron")
+    (version "1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnu/micron/micron-" version ".tar.gz"))
+       (sha256
+        (base32 "196dfcjijzsnddc9zzkyl0z22p4xkz9nl3jbdaxrikv0b8pncvh3"))))
+    (build-system gnu-build-system)
+    (home-page "https://www.gnu.org/software/micron/")
+    (synopsis "Implementation of the UNIX cron daemon")
+    (description
+     "GNU Micron is an implementation of the UNIX cron daemon, a program that
+executes periodically various tasks. It provides a flexible job scheduler, which
+offers complete control over the execution of the scheduled commands and contains
+additional organizational features.")
+    (license license:gpl3+)))
\ No newline at end of file