diff mbox series

[bug#58142,7/7] gnu: tealdeer: Update to 1.5.0.

Message ID b28a3a72f1db76757f5eb8db77382341ea33537b.1664369657.git.code@greghogan.com
State New
Headers show
Series Update tealdeer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Sept. 28, 2022, 1:03 p.m. UTC
* gnu/packages/rust-apps.scm (tealdeer): Update to 1.5.0.
[arguments]<#:cargo-test-flags>: Skip new network tests.
<#:cargo-inputs>: Add rust-clap, rust-zip; update rust-env-logger,
rust-pager, rust-reqwest.
<#:cargo-development-inputs>: Update rust-assert-cmd, rust-predicates;
remove rust-remove-dir-all.
---
 gnu/packages/rust-apps.scm | 23 ++++++++++++-----------
 1 file changed, 12 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 74581bc1e5..d68a83d015 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1739,7 +1739,7 @@  (define-public swayhide
 (define-public tealdeer
   (package
     (name "tealdeer")
-    (version "1.4.1")
+    (version "1.5.0")
     (source
      (origin
        (method url-fetch)
@@ -1748,7 +1748,7 @@  (define-public tealdeer
         (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "0cwf46k2rszcpydrqajnm4dvhggr3ms7sjma0jx02ch4fjicxch7"))))
+         "118hmrz58x1s0cgsg2dka7mq9rb01p5ivrd4njd03dnabhndihs6"))))
     (build-system cargo-build-system)
     (arguments
      `(#:phases
@@ -1775,31 +1775,32 @@  (define-public tealdeer
          "--skip=test_markdown_rendering"
          "--skip=test_spaces_find_command"
          "--skip=test_autoupdate_cache"
+         "--skip=test_cache_location_not_a_directory"
+         "--skip=test_create_cache_directory_path"
          "--skip=test_update_cache")
        #:cargo-inputs
        (("rust-ansi-term" ,rust-ansi-term-0.12)
         ("rust-app-dirs2" ,rust-app-dirs2-2)
         ("rust-atty" ,rust-atty-0.2)
+        ("rust-clap" ,rust-clap-3.0.0-rc.11)
         ("rust-docopt" ,rust-docopt-1)
-        ("rust-env-logger" ,rust-env-logger-0.7)
+        ("rust-env-logger" ,rust-env-logger-0.9)
         ("rust-flate2" ,rust-flate2-1)
         ("rust-log" ,rust-log-0.4)
-        ("rust-pager" ,rust-pager-0.15)
-        ("rust-reqwest" ,rust-reqwest-0.10)
+        ("rust-pager" ,rust-pager-0.16)
+        ("rust-reqwest" ,rust-reqwest-0.11)
         ("rust-serde" ,rust-serde-1)
         ("rust-serde-derive" ,rust-serde-derive-1)
         ("rust-tar" ,rust-tar-0.4)
         ("rust-toml" ,rust-toml-0.5)
         ("rust-walkdir" ,rust-walkdir-2)
-        ("rust-xdg" ,rust-xdg-2))
+        ("rust-xdg" ,rust-xdg-2)
+        ("rust-zip" ,rust-zip-0.5))
        #:cargo-development-inputs
-       (("rust-assert-cmd" ,rust-assert-cmd-1)
+       (("rust-assert-cmd" ,rust-assert-cmd-2)
         ("rust-escargot" ,rust-escargot-0.5)
         ("rust-filetime" ,rust-filetime-0.2)
-        ("rust-predicates" ,rust-predicates-1)
-        ;; This earlier version is required to fix a bug.
-        ;; Remove rust-remove-dir-all-0.5.2 when tealdeer gets upgraded
-        ("rust-remove-dir-all" ,rust-remove-dir-all-0.5.2)
+        ("rust-predicates" ,rust-predicates-2)
         ("rust-tempfile" ,rust-tempfile-3))))
     (native-inputs
      (list pkg-config))