@@ -26462,6 +26462,41 @@ (define-public python-more-itertools
working with iterables.")
(license license:expat)))
+;; Needed for python-yt, older version fails with exception: E ImportError:
+;; cannot import name 'mark_ends' from 'more_itertools'
+;; (<...>more_itertools/__init__.py)
+(define-public python-more-itertools-next
+ (package
+ (inherit python-more-itertools)
+ (name "python-more-itertools")
+ (version "10.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "more-itertools" version))
+ (sha256
+ (base32
+ "1q9rq9g026m4wl6ki2q8pw7xbc02vl34qqw702h9jgixqj0b9k4g"))
+ (snippet
+ ;; distutils.errors.DistutilsOptionError: No configuration found for
+ ;; dynamic 'description'. Some dynamic fields need to be specified via
+ ;; `tool.setuptools.dynamic`others must be specified via the equivalent
+ ;; attribute in `setup.py`.
+ '(delete-file "setup.py"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest")))))))
+ (native-inputs
+ (list python-flit-core))
+ (propagated-inputs
+ (list python-six))))
+
(define-public python-latexcodec
(package
(name "python-latexcodec")