diff mbox series

[bug#51305,1/4] gnu: Add julia-gr-jll.

Message ID b239a8b691c8cd767382ea367c38fba36332c9c9.1634733947.git.efraim@flashner.co.il
State Accepted
Headers show
Series More julia packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Oct. 20, 2021, 12:51 p.m. UTC
* gnu/packages/julia-jll.scm (julia-gr-jll): New variable.
---
 gnu/packages/julia-jll.scm | 50 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

Comments

Simon Tournier Oct. 21, 2021, 1:01 p.m. UTC | #1
Hi,

On mer., 20 oct. 2021 at 15:51, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-jll.scm (julia-gr-jll): New variable.
> ---
>  gnu/packages/julia-jll.scm | 50 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 50 insertions(+)

LGTM, except...

> +    (inputs
> +     `(("gr-framework" ,gr-framework)))
> +    (propagated-inputs
> +     `(("julia-jllwrappers" ,julia-jllwrappers)
> +       ("julia-bzip2-jll" ,julia-bzip2-jll)
> +       ("julia-cairo-jll" ,julia-cairo-jll)
> +       ("julia-ffmpeg-jll" ,julia-ffmpeg-jll)
> +       ("julia-fontconfig-jll" ,julia-fontconfig-jll)
> +       ("julia-glfw-jll" ,julia-glfw-jll)
> +       ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
> +       ("julia-libpng-jll" ,julia-libpng-jll)
> +       ("julia-libtiff-jll" ,julia-libtiff-jll)
> +       ("julia-pixman-jll" ,julia-pixman-jll)
> +       ("julia-qt5base-jll" ,julia-qt5base-jll)
> +       ("julia-zlib-jll" ,julia-zlib-jll)))

...is it possible to alphabetically sort?  I find easier for maintenance
later.  WDYT?

Cheers,
simon
Efraim Flashner Oct. 24, 2021, 6:16 a.m. UTC | #2
On Thu, Oct 21, 2021 at 03:01:55PM +0200, zimoun wrote:
> Hi,
> 
> On mer., 20 oct. 2021 at 15:51, Efraim Flashner <efraim@flashner.co.il> wrote:
> > * gnu/packages/julia-jll.scm (julia-gr-jll): New variable.
> > ---
> >  gnu/packages/julia-jll.scm | 50 ++++++++++++++++++++++++++++++++++++++
> >  1 file changed, 50 insertions(+)
> 
> LGTM, except...
> 
> > +    (inputs
> > +     `(("gr-framework" ,gr-framework)))
> > +    (propagated-inputs
> > +     `(("julia-jllwrappers" ,julia-jllwrappers)
> > +       ("julia-bzip2-jll" ,julia-bzip2-jll)
> > +       ("julia-cairo-jll" ,julia-cairo-jll)
> > +       ("julia-ffmpeg-jll" ,julia-ffmpeg-jll)
> > +       ("julia-fontconfig-jll" ,julia-fontconfig-jll)
> > +       ("julia-glfw-jll" ,julia-glfw-jll)
> > +       ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
> > +       ("julia-libpng-jll" ,julia-libpng-jll)
> > +       ("julia-libtiff-jll" ,julia-libtiff-jll)
> > +       ("julia-pixman-jll" ,julia-pixman-jll)
> > +       ("julia-qt5base-jll" ,julia-qt5base-jll)
> > +       ("julia-zlib-jll" ,julia-zlib-jll)))
> 
> ...is it possible to alphabetically sort?  I find easier for maintenance
> later.  WDYT?

the julia-jllwrappers are intentionally at the top of the list because
then all the package jll packages are grouped together.
Simon Tournier Oct. 24, 2021, 7:54 a.m. UTC | #3
Hi Efraim,

On Sun, 24 Oct 2021 at 09:16, Efraim Flashner <efraim@flashner.co.il> wrote:

> the julia-jllwrappers are intentionally at the top of the list because
> then all the package jll packages are grouped together.

It makes sense. :-)

Thanks,
simon
Efraim Flashner Oct. 24, 2021, 8:42 a.m. UTC | #4
On Sun, Oct 24, 2021 at 09:54:22AM +0200, zimoun wrote:
> Hi Efraim,
> 
> On Sun, 24 Oct 2021 at 09:16, Efraim Flashner <efraim@flashner.co.il> wrote:
> 
> > the julia-jllwrappers are intentionally at the top of the list because
> > then all the package jll packages are grouped together.
> 
> It makes sense. :-)
> 
> Thanks,
> simon

Thanks for the reviews! Patches pushed.
diff mbox series

Patch

diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index d3677d0a33..51643819ae 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -36,6 +36,7 @@  (define-module (gnu packages julia-jll)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages graphics)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
@@ -522,6 +523,55 @@  (define-public julia-glib-jll
     (description "This package provides a wrapper for the glib library.")
     (license license:expat)))
 
+(define-public julia-gr-jll
+  (package
+    (name "julia-gr-jll")
+    (version "0.58.1+0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/GR_jll.jl")
+               (commit (string-append "GR-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "16m22n0wh86v3lh0im2pc9bg381djbmqji5hjx42j6aaz634gqiq"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                   (("generate_wrapper_header.*")
+                    (string-append
+                      "generate_wrapper_header(\"GR\", \""
+                      (assoc-ref inputs "gr-framework") "\")\n"))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("gr-framework" ,gr-framework)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)
+       ("julia-bzip2-jll" ,julia-bzip2-jll)
+       ("julia-cairo-jll" ,julia-cairo-jll)
+       ("julia-ffmpeg-jll" ,julia-ffmpeg-jll)
+       ("julia-fontconfig-jll" ,julia-fontconfig-jll)
+       ("julia-glfw-jll" ,julia-glfw-jll)
+       ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
+       ("julia-libpng-jll" ,julia-libpng-jll)
+       ("julia-libtiff-jll" ,julia-libtiff-jll)
+       ("julia-pixman-jll" ,julia-pixman-jll)
+       ("julia-qt5base-jll" ,julia-qt5base-jll)
+       ("julia-zlib-jll" ,julia-zlib-jll)))
+    (home-page "https://github.com/JuliaBinaryWrappers/GR_jll.jl")
+    (synopsis "GR framework library wrappers")
+    (description "This package provides a wrapper for the GR framework.")
+    (license license:expat)))
+
 (define-public julia-gumbo-jll
   (package
     (name "julia-gumbo-jll")