diff mbox series

[bug#38894] gnu: Add gssdp.

Message ID b1f0720a5a691a838d2c82e106d0f69529daf561.camel@disroot.org
State Accepted
Headers show
Series [bug#38894] gnu: Add gssdp. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 3, 2020, 3:43 p.m. UTC
Hello Guix!

Please find the attached patch for adding gssdp.

Regards,
RG.

Comments

Danny Milosavljevic Jan. 12, 2020, 10:18 p.m. UTC | #1
Please use 

  guix lint gssdp

to validate this patch.
Danny Milosavljevic Jan. 12, 2020, 10:20 p.m. UTC | #2
gobject-introspection should be a native-input, and vala too.
Raghav Gururajan Jan. 12, 2020, 10:27 p.m. UTC | #3
Hello Danny!

> gobject-introspection should be a native-input, and vala too.

Please find the revised patch attached.

Regards,
RG.
Danny Milosavljevic Jan. 12, 2020, 10:31 p.m. UTC | #4
The license is gpl 2 or later, right?
Raghav Gururajan Jan. 12, 2020, 10:34 p.m. UTC | #5
Hello Danny!

> The license is gpl 2 or later, right?

It says GPL v2 (https://gitlab.gnome.org/GNOME/gssdp/blob/master/COPYING).

Regards,
RG.
Danny Milosavljevic Jan. 12, 2020, 10:40 p.m. UTC | #6
That file contains LGPL 2 (not GPL2).

Moreover, the important part is whether the source files contain a comment
header which specifies "or later" or not.

Please provide a license review of the source files that are the source of
files that are installed (only).
Raghav Gururajan Jan. 12, 2020, 10:53 p.m. UTC | #7
Hello Danny!

> That file contains LGPL 2 (not GPL2).
> 
> Moreover, the important part is whether the source files contain a comment
> header which specifies "or later" or not.
> 
> Please provide a license review of the source files that are the source of
> files that are installed (only).

Sorry, I misunderstood the Library<-->Lesser.

Please find the revised patch attached.

Regards,
RG.
Danny Milosavljevic Jan. 13, 2020, 7:38 a.m. UTC | #8
Pushed to guix master as commit e2aed29c798711a765dc3cd7e76f423b2447d22c
after moving gtk-doc to native-inputs.
diff mbox series

Patch

From edc99a3deb39e2c9e4395f59dbf69b9f5b1721ba Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 10:38:26 -0500
Subject: [PATCH] gnu: Add gssdp.

* gnu/packages/gnome.scm (gssdp): New variable.
---
 gnu/packages/gnome.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1e713d4fe1..b32fc43eec 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,35 @@  Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public gssdp
+  (package
+   (name "gssdp")
+   (version "1.2.2")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "195hi10vrsvh6i927mm6rm1ld5sxah3h5sr3bsjm90vb8lxrxfya"))))
+   (build-system meson-build-system)
+   (native-inputs
+    `(("gettext" ,gettext-minimal)
+      ("glib:bin" ,glib "bin")
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("gtk-doc" ,gtk-doc)
+      ("gobject-introspection" ,gobject-introspection)
+      ("gtk+" ,gtk+)
+      ("libsoup" ,libsoup)
+      ("vala" ,vala)))
+   (synopsis "GObject-based API over SSDP for GNOME desktop")
+   (description "A GObject-based API for handling resource discovery
+and announcement over SSDP.")
+   (home-page "https://gitlab.gnome.org/GNOME/gssdp")
+   (license license:gpl2)))
+
 (define-public libmediaart
   (package
     (name "libmediaart")
-- 
2.24.1