diff mbox series

[bug#67428,01/12] gnu: Add cl-interface

Message ID b1ec436d4870000a8a92bbc9c3c1d5793b9ea191.1700820457.git.michal_atlas+git@posteo.net
State New
Headers show
Series gnu: Add Quil Quantum VM (QVM) and CL dependencies | expand

Commit Message

Michal Atlas Nov. 24, 2023, 4:19 p.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-interface, ecl-interface, cl-interface): New variables.

Change-Id: Idd400c4cd295437db08de203de22f83f6220997f
---
 gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

jgart Nov. 24, 2023, 4:22 p.m. UTC | #1
Hi Michal,

Thanks for the patch!

Can you refactor this patch and send a v2 putting the commit hash in the let block with a revision number?

Revision numbers start at 0.

See how I fixed up sbcl-lisp-critic for an example.

all best,

jgart
Guillaume Le Vaillant Jan. 24, 2024, 5:57 p.m. UTC | #2
"jgart" <jgart@dismail.de> skribis:

> Hi Michal,
>
> Thanks for the patch!
>
> Can you refactor this patch and send a v2 putting the commit hash in the let block with a revision number?
>
> Revision numbers start at 0.
>
> See how I fixed up sbcl-lisp-critic for an example.
>
> all best,
>
> jgart

Hi jgart,
Will you continue to review/merge this patch series?
I could take a look at it if you don't have the time.
jgart Jan. 25, 2024, 12:28 a.m. UTC | #3
Hi Guillaume,

Yes, please do.

I don't have the time at the moment to review this one.

I'm going to try to spend some limited time reviewing in the next two weeks starting from the 29th when I take PTO.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4bc3c71a54..0e0e849ea4 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20433,6 +20433,35 @@  (define-public sbcl-3d-quaternions
 (define-public cl-3d-quaternions
   (sbcl-package->cl-source-package sbcl-3d-quaternions))
 
+(define-public sbcl-interface
+  (package
+    (name "sbcl-interface")
+    (version "0.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/stylewarning/interface")
+             (commit "6d8bd74214053debcbc0b174d65ea73c271c1563")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0h1bckhyig2znl6nrd3agjzz7knrm2kyh2vfyk7j60kzki9rpzxy"))))
+    (build-system asdf-build-system/sbcl)
+    (inputs (list sbcl-alexandria sbcl-global-vars))
+    (synopsis
+     "This system contains an implementation of interfaces and implementations")
+    (description
+     "Broadly speaking, an \"interface\" is some collection of 
+function \"prototypes\" that a valid implementation must implement.")
+    (home-page "https://github.com/stylewarning/interface")
+    (license license:bsd-3)))
+
+(define-public ecl-interface
+  (sbcl-package->ecl-package sbcl-interface))
+
+(define-public cl-interface
+  (sbcl-package->cl-source-package sbcl-interface))
+
 (define-public sbcl-messagebox
   (let ((commit "ea3688d9a9954bee7079c0173bc7b3f327021e9f")
         (revision "1"))