@@ -566,6 +566,33 @@ (define-public aflplusplus
redqueen, AFLfast++ power schedules, MOpt mutators, unicorn_mode, etc.
@end itemize")))
+(define-public backward-cpp
+ (package
+ (name "backward-cpp")
+ (version "1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bombela/backward-cpp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b2h03iwfhcsg8i4f125mlrjf8l1y7qsr2gsbkv0z03i067lykns"))))
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "-DBACKWARD_SHARED=ON")))
+ (build-system cmake-build-system)
+ (inputs
+ (list libiberty zlib))
+ (synopsis "Stack trace pretty printer for C++")
+ (description
+ "Backward-cpp is a stack trace pretty printer for C++.
+It can print annotated stack traces using debug info in the executable.")
+ (home-page "https://github.com/bombela/backward-cpp")
+ (license license:expat)))
+
(define-public stress-make
(let ((commit "97815bed8060de33952475b3498767c91f59ffd9")
(revision "2")) ;No official source distribution
From 91bf9bff2c3c365d006a0e88024db50f416cd436 Mon Sep 17 00:00:00 2001 Message-ID: <91bf9bff2c3c365d006a0e88024db50f416cd436.1724856297.git.adam.faiz@disroot.org> From: AwesomeAdam54321 <adam.faiz@disroot.org> Date: Sun, 11 Aug 2024 08:40:08 +0800 Subject: [PATCH v2 1/4] gnu: Add backward-cpp. * gnu/packages/debug.scm (backward-cpp): New variable. --- gnu/packages/debug.scm | 27 +++++++++++++++++++++++++++ 1 file changed, 27 insertions(+) base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8