diff mbox series

[bug#66217,20/22] gnu: teensy-loader-cli: Use gexps.

Message ID b1b75dd03c019a8f5ba82c8b26c6d49045c7759b.1695754731.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Add ErgoDox firmware packages | expand

Commit Message

Maxim Cournoyer Sept. 26, 2023, 7:04 p.m. UTC
* gnu/packages/flashing-tools.scm (teensy-loader-cli) [arguments]: Use gexps.
---

 gnu/packages/flashing-tools.scm | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index d9f59cd0b7c..a17547cbcd7 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -234,16 +234,15 @@  (define-public teensy-loader-cli
        (patches (search-patches "teensy-loader-cli-help.patch"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f ;; Makefile has no test target
-       #:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin")))
-               (install-file "teensy_loader_cli" bin)))))))
+     (list
+      #:tests? #f ;; Makefile has no test target
+      #:make-flags #~(list "CC=gcc" (string-append "PREFIX=" #$output))
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'configure)
+                   (replace 'install
+                     (lambda _
+                       (install-file "teensy_loader_cli"
+                                     (string-append #$output "/bin")))))))
     (inputs (list libusb-compat))       ;only compatible with libusb 0.1
     (synopsis "Command line firmware uploader for Teensy development boards")
     (description