[bug#77056,1/1] gnu: gnome-packagekit: Run glib-or-gtk? phases.
Commit Message
From: Noé Lopez <noelopez@free.fr>
I am not sure relying on profile hooks works, since gnome-packagekit would not
start from guix shell. Using glib-or-gtk does make it start, which is better
to not rely on the profile.
* gnu/packages/package-management.scm (gnome-packagekit)
[source]: Use gnome mirrors.
[native-inputs]: Change gnu-gettext to gettext-minimal.
[inputs]: Remove polkit.
[arguments]: Use glib-or-gtk? phases.
Change-Id: I11c80d7470bd7f25888235afb4cadc9f1313ba31
---
gnu/packages/package-management.scm | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)
@@ -2409,14 +2409,14 @@ (define-public gnome-packagekit
(name "gnome-packagekit")
(version "43.0")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.gnome.org/GNOME/gnome-packagekit.git")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnome/sources/" name "/"
+ (version-major version) "/"
+ name "-" version ".tar.xz"))
(sha256
(base32
- "1fnspk8wfh3v663qpqq3m1fgp21nskgisidihx41wgcsbzbvp1a5"))))
+ "15giqmk8w375kkyzmwzfc9xnyafqzp86ncbh5zmb48x9aak5b96d"))))
(build-system meson-build-system)
(arguments
(list #:configure-flags
@@ -2430,13 +2430,14 @@ (define-public gnome-packagekit
(add-before 'install 'setenv
(lambda _
;; Prevent gtk-update-icon-cache, glib-compile-schemas,
- ;; update-desktop-database
- ;; (since we are doing it ourselves with a profile hook).
- (setenv "DESTDIR" "/"))))))
+ ;; update-desktop-database (since we are doing it ourselves with
+ ;; glib-or-gtk phases).
+ (setenv "DESTDIR" "/"))))
+ #:glib-or-gtk? #t))
(native-inputs
- (list gnu-gettext pkg-config (list glib "bin") xorg-server-for-tests))
+ (list gettext-minimal pkg-config (list glib "bin") xorg-server-for-tests))
(inputs
- (list glib gtk+ packagekit polkit))
+ (list glib gtk+ packagekit))
(synopsis "GNOME frontend for PackageKit")
(description "This package provides a PackageKit frontend for GNOME.
PackageKit is a common unified interface for package managers.")